summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2022-09-04 00:00:00 +0000
committerengn33r <engn33r@users.noreply.github.com>2022-09-04 00:00:00 +0000
commit37429a3efa1238cb5b6e5c056dd4e9190575d5ca (patch)
tree31ccfbee99e1611cb1dbc86dc6a466e86b0a81a9
parent3baacdafe246c4eb93b41850bb29bda7b73c5fc3 (diff)
downloadwebsocket-client-37429a3efa1238cb5b6e5c056dd4e9190575d5ca.tar.gz
1.4.1v1.4.1
-rw-r--r--ChangeLog5
-rw-r--r--docs/source/conf.py2
-rw-r--r--setup.py2
-rw-r--r--websocket/__init__.py2
4 files changed, 8 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 703afb6..b80d594 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,11 @@
ChangeLog
============
+- 1.4.1
+ - Fix stack growth bug when `run_forever` reconnects (#854)
+ - Add doctest CI for sphinx docs code examples (d150099)
+ - General docs improvements
+
- 1.4.0
- Fix automatic reconnect with `run_forever` (#838)
- Allow a timeout to be set when using a proxy (#842)
diff --git a/docs/source/conf.py b/docs/source/conf.py
index 3355879..1d49533 100644
--- a/docs/source/conf.py
+++ b/docs/source/conf.py
@@ -34,7 +34,7 @@ copyright = '2022'
author = 'liris'
# The full version, including alpha/beta/rc tags
-release = '1.4.0'
+release = '1.4.1'
# -- General configuration ---------------------------------------------------
diff --git a/setup.py b/setup.py
index a06b204..b596b64 100644
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ See the License for the specific language governing permissions and
limitations under the License.
"""
-VERSION = "1.4.0"
+VERSION = "1.4.1"
install_requires = []
tests_require = []
diff --git a/websocket/__init__.py b/websocket/__init__.py
index 21965a4..720a842 100644
--- a/websocket/__init__.py
+++ b/websocket/__init__.py
@@ -23,4 +23,4 @@ from ._exceptions import *
from ._logging import *
from ._socket import *
-__version__ = "1.4.0"
+__version__ = "1.4.1"