summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2022-08-24 00:00:00 +0000
committerengn33r <engn33r@users.noreply.github.com>2022-08-24 00:00:00 +0000
commit14b102d809295328fcf9fa87b396eff05b2d039f (patch)
tree815604b100a0772defe74252f534f087a2ada2ab
parent510583d434cdd64c0a6f53253b6336300365c153 (diff)
downloadwebsocket-client-14b102d809295328fcf9fa87b396eff05b2d039f.tar.gz
1.4.0v1.4.0
-rw-r--r--ChangeLog4
-rw-r--r--docs/source/conf.py2
-rw-r--r--setup.py2
-rw-r--r--websocket/__init__.py2
4 files changed, 7 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 5666745..703afb6 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,10 @@
ChangeLog
============
+- 1.4.0
+ - Fix automatic reconnect with `run_forever` (#838)
+ - Allow a timeout to be set when using a proxy (#842)
+
- 1.3.3
- Fix unclosed socket error (#826)
- Update header dict access (#818)
diff --git a/docs/source/conf.py b/docs/source/conf.py
index a35c4ed..4c087e9 100644
--- a/docs/source/conf.py
+++ b/docs/source/conf.py
@@ -34,7 +34,7 @@ copyright = '2022'
author = 'liris'
# The full version, including alpha/beta/rc tags
-release = '1.3.3'
+release = '1.4.0'
# -- General configuration ---------------------------------------------------
diff --git a/setup.py b/setup.py
index 4a792ba..a06b204 100644
--- a/setup.py
+++ b/setup.py
@@ -21,7 +21,7 @@ See the License for the specific language governing permissions and
limitations under the License.
"""
-VERSION = "1.3.3"
+VERSION = "1.4.0"
install_requires = []
tests_require = []
diff --git a/websocket/__init__.py b/websocket/__init__.py
index 6e018cb..2a37af5 100644
--- a/websocket/__init__.py
+++ b/websocket/__init__.py
@@ -23,4 +23,4 @@ from ._exceptions import *
from ._logging import *
from ._socket import *
-__version__ = "1.3.3"
+__version__ = "1.4.0"