summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2021-05-04 21:33:13 -0400
committerengn33r <engn33r@users.noreply.github.com>2021-05-04 21:33:13 -0400
commit8f072582d4bc21bb19fb4adee55a305da12790c1 (patch)
tree47e3d11415b75139fd7cce3ef330204a438e254a
parent5d54a56f89ad845f202245cf762916fa15a97ab5 (diff)
downloadwebsocket-client-python2.tar.gz
-rw-r--r--ChangeLog12
-rw-r--r--docs/source/conf.py2
-rw-r--r--setup.py2
-rw-r--r--websocket/__init__.py2
4 files changed, 15 insertions, 3 deletions
diff --git a/ChangeLog b/ChangeLog
index 1b7d84a..17a647a 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,6 +1,18 @@
ChangeLog
============
+- 0.59.0
+
+ - Last main release to support Python 2
+ - Fix Python 2 urlparse scheme (#332)
+ - Add support for headers with multiple values (#627)
+ - Add debug support for reserved custom status codes (#639)
+ - Allow multiple Set-Cookie: headers (#649)
+ - Simplified cookie sorting (#662)
+ - Add no_proxy support (#671)
+ - Add Host header to HTTP proxy request (#677)
+ - Improve PEP8 style compliance (dc3f5c4)
+
- 0.58.0
- Fix README typos (#659)
diff --git a/docs/source/conf.py b/docs/source/conf.py
index 9f44b01..f7f5c57 100644
--- a/docs/source/conf.py
+++ b/docs/source/conf.py
@@ -34,7 +34,7 @@ copyright = '2021'
author = 'liris'
# The full version, including alpha/beta/rc tags
-release = '0.58.0'
+release = '0.59.0'
# -- General configuration ---------------------------------------------------
diff --git a/setup.py b/setup.py
index 8a666f1..0b743a2 100644
--- a/setup.py
+++ b/setup.py
@@ -27,7 +27,7 @@ import sys
from setuptools import setup
import pkg_resources
-VERSION = "0.58.0"
+VERSION = "0.59.0"
install_requires = ["six"]
tests_require = []
diff --git a/websocket/__init__.py b/websocket/__init__.py
index ce1b787..f2c7b44 100644
--- a/websocket/__init__.py
+++ b/websocket/__init__.py
@@ -25,4 +25,4 @@ from ._exceptions import *
from ._logging import *
from ._socket import *
-__version__ = "0.58.0"
+__version__ = "0.59.0"