summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorengn33r <engn33r@users.noreply.github.com>2021-02-24 23:18:10 -0500
committerengn33r <engn33r@users.noreply.github.com>2021-02-24 23:18:10 -0500
commitaa561086a4342c962fa5d4333f66b85c728c3624 (patch)
tree04b826038aefe6454f94d263a890819db8896d33
parente39e64886d740eab92bfecb9351bb5d7e800a88b (diff)
downloadwebsocket-client-codecov-ci-dev.tar.gz
Update contribution guidelinescodecov-ci-dev
-rw-r--r--CONTRIBUTING.md57
-rw-r--r--README.md19
-rw-r--r--docs/source/contributing.rst20
3 files changed, 68 insertions, 28 deletions
diff --git a/CONTRIBUTING.md b/CONTRIBUTING.md
new file mode 100644
index 0000000..9908aa1
--- /dev/null
+++ b/CONTRIBUTING.md
@@ -0,0 +1,57 @@
+# Contributing
+
+Hello :wave: and thank you for contributing! :tada:
+
+Before you contribute, please take a minute to review the contribution process
+based on what you want to do.
+
+## I got an error or I have a question
+
+Great! We are happy to help. Before you ask your question, please check if your
+question can be answered from the following 5 steps:
+- [ ] The [project documentation examples](https://websocket-client.readthedocs.io/en/latest/examples.html)
+- [ ] The [project documentation FAQ](https://websocket-client.readthedocs.io/en/latest/faq.html)
+- [ ] Search for your question in [old existing issues](https://github.com/websocket-client/websocket-client/issues)
+- [ ] If you encountered an error message, try googling the error message and see if you find an answer
+- [ ] Check if the same issue exists if you uninstall the websocket-client
+library on your system (using `pip uninstall websocket-client` or maybe
+`pip3 uninstall websocket-client`) and install the
+[latest master branch](https://github.com/websocket-client/websocket-client)
+directly from GitHub by using `python setup.py install`
+(see [installation info](https://github.com/websocket-client/websocket-client#installation))
+
+If you did not get your question answered from these 5 steps, then please open a
+new issue and ask your question! When you explain your problem, please:
+- [ ] [Enable the tracing feature](https://websocket-client.readthedocs.io/en/latest/examples.html#debug-and-logging-options)
+and include the entire debug trace of your connection process in the issue
+- [ ] Add an explanation for what you are trying to accomplish. If you can
+provide your code (or example code) in the issue, this helps a lot!
+
+## I have a suggestion or idea
+
+Great! Please make a new issue an explain your idea, but first do a quick search
+in [old existing issues](https://github.com/websocket-client/websocket-client/issues)
+to see if someone already proposed the same idea.
+
+## I want to contribute code
+
+Great! In your pull request (PR), please explain:
+1. What is the problem with the current code
+2. How your changes make it better
+3. Provide some example code that can allow someone else to recreate the
+problem with the current code and test your solution (if possible to recreate).
+
+## I want to contribute documentation
+
+Great! To edit the [project documentation](https://websocket-client.readthedocs.io),
+it is recommended that you install Sphinx and build the updated documentation
+locally before submitting your edits. The Sphinx dependencies can be
+installed by navigating to the `docs/source` directory and running `pip install
+-r requirements.txt`. To build a new version of the documentation, change
+directories (or `cd`) to the `docs/` directory and run `make clean html`.
+Any build warnings or errors will be displayed in your terminal, and the new
+documentation will then be available in the `docs/build/html/` directory.
+You may also find the
+[Sphinx documentation style guide](https://documentation-style-guide-sphinx.readthedocs.io/en/latest/style-guide.html)
+useful when editing reStructuredText (reST), which is quite
+different from Markdown.
diff --git a/README.md b/README.md
index a8efe12..303ad29 100644
--- a/README.md
+++ b/README.md
@@ -6,14 +6,10 @@
# websocket-client
-The websocket-client module is a WebSocket client for Python. It provides access
-to low level APIs for WebSockets. All APIs are for synchronous functions.
-
-websocket-client supports only [hybi-13](https://tools.ietf.org/html/draft-ietf-hybi-thewebsocketprotocol-13).
-
-## License
-
-- LGPL version 2.1
+websocket-client is a WebSocket client for Python. It provides access
+to low level APIs for WebSockets. websocket-client implements version
+[hybi-13](https://tools.ietf.org/html/draft-ietf-hybi-thewebsocketprotocol-13)
+of the WebSocket procotol.
## Documentation
@@ -22,8 +18,7 @@ This project's documentation can be found at
## Contributing
-Please see the contribution guidelines at
-[https://websocket-client.readthedocs.io/en/latest/contributing.html](https://websocket-client.readthedocs.io/en/latest/contributing.html)
+Please see the [contribution guidelines](https://github.com/websocket-client/websocket-client/blob/master/CONTRIBUTING.md)
## Installation
@@ -43,6 +38,10 @@ support was first introduced in version 0.14.0, but is a work in progress.
Check out the documentation's FAQ for additional guidelines:
[https://websocket-client.readthedocs.io/en/latest/faq.html](https://websocket-client.readthedocs.io/en/latest/faq.html)
+## License
+
+- LGPL version 2.1
+
### Performance
The `send` and `validate_utf8` methods are very slow in pure Python. You can
diff --git a/docs/source/contributing.rst b/docs/source/contributing.rst
index e033981..884a9d9 100644
--- a/docs/source/contributing.rst
+++ b/docs/source/contributing.rst
@@ -2,21 +2,5 @@
Contributing
############
-All contributions are welcome! To submit a suggestion, you can either create a
-new issue (after searching for an existing issue that covers the same topic)
-or submit a pull request with the edits that you would like to see in the
-repository.
-
-If you are contributing to the project's documentation, which is still in its
-early stages, it is recommended that you install Sphinx and build the updated
-documentation locally before submitting
-your edits. The Sphinx dependencies can be installed by navigating to the
-docs/source directory and running ``pip install -r requirements.txt``. To build
-a new version of the documentation, navigate to the docs/ directory and run
-``make clean html``. Any build warnings or errors will be displayed in your
-terminal, and the new documentation will then be available in the
-docs/build/html directory. You may also find the
-`Sphinx documentation style guide
-<https://documentation-style-guide-sphinx.readthedocs.io/en/latest/style-guide.html>`_
-useful when editing reStructuredText (reST), which is quite different from
-Markdown.
+Contributions are welcome! See this project's
+`contributing guidelines <https://github.com/websocket-client/websocket-client/blob/master/CONTRIBUTING.md>`_