summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris McDonough <chrism@plope.com>2014-05-14 21:30:18 -0400
committerChris McDonough <chrism@plope.com>2014-05-14 21:30:18 -0400
commitae0ac90f22f9e1ff351e445f92330efd89195f51 (patch)
tree5594bab03c2ba1a9c0e587879b8e0e5d5f4b9352
parent79f75c132faba6bef935f32c0a3349f0e73b0055 (diff)
downloadwebob-ae0ac90f22f9e1ff351e445f92330efd89195f51.tar.gz
prep for 1.41.4
-rw-r--r--docs/news.txt11
-rw-r--r--setup.py3
-rw-r--r--tests/test_util.py9
-rw-r--r--webob/util.py10
4 files changed, 9 insertions, 24 deletions
diff --git a/docs/news.txt b/docs/news.txt
index 8df2057..4f12bf5 100644
--- a/docs/news.txt
+++ b/docs/news.txt
@@ -1,21 +1,22 @@
News
====
-unreleased
-----------
+1.4 (2013-05-14)
+----------------
Features
~~~~~~~~
-- Remove webob.__version__, the version number had not been kept in sync with
- the official pkg version.
+- Remove ``webob.__version__``, the version number had not been kept in sync
+ with the official pkg version. To obtain the WebOb version number, use
+ ``pkg_resources.get_distribution('webob').version`` instead.
Bug Fixes
~~~~~~~~~
- Fix a bug in ``EmptyResponse`` that prevents it from setting self.close as
appropriate due to testing truthiness of object rather than if it is
- something other than None
+ something other than ``None``.
- Fix a bug in ``SignedSerializer`` preventing secrets from containing
higher-order characters. See https://github.com/Pylons/webob/issues/136
diff --git a/setup.py b/setup.py
index 247e098..abb65c4 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,6 @@
from setuptools import setup
-version = '1.3.1'
+version = '1.4'
testing_extras = ['nose', 'coverage']
@@ -41,7 +41,6 @@ You may install the `in-development version of WebOb
"Programming Language :: Python :: 3.2",
"Programming Language :: Python :: 3.3",
"Programming Language :: Python :: 3.4",
- "Programming Language :: Python :: 3.4",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
],
diff --git a/tests/test_util.py b/tests/test_util.py
index 65cff49..bb513ef 100644
--- a/tests/test_util.py
+++ b/tests/test_util.py
@@ -43,15 +43,8 @@ class Test_warn_deprecation(unittest.TestCase):
from webob.util import warn_deprecation
self.assertRaises(DeprecationWarning, warn_deprecation, 'foo', v[:3], 1)
- def test_warn_deprecation_next_version(self):
- # Bump this at the same time you bump warn_deprecation in util.py
- v = '1.4.0'
- from webob.util import warn_deprecation
- warn_deprecation('foo', v[:3], 1)
- self.assertEqual(len(self.warnings), 1)
-
def test_warn_deprecation_future_version(self):
v = '9.9.9'
from webob.util import warn_deprecation
warn_deprecation('foo', v[:3], 1)
- self.assertEqual(len(self.warnings), 2)
+ self.assertEqual(len(self.warnings), 1)
diff --git a/webob/util.py b/webob/util.py
index d79c987..fa34523 100644
--- a/webob/util.py
+++ b/webob/util.py
@@ -47,18 +47,10 @@ def header_docstring(header, rfc_section):
def warn_deprecation(text, version, stacklevel):
# version specifies when to start raising exceptions instead of warnings
- if version == '1.2':
+ if version in ('1.2', '1.3', '1.4'):
raise DeprecationWarning(text)
- elif version == '1.3':
- raise DeprecationWarning(text)
- elif version == '1.4':
- cls = DeprecationWarning
else:
cls = DeprecationWarning
- warnings.warn("Unknown warn_deprecation version arg: %r" % version,
- RuntimeWarning,
- stacklevel=1
- )
warnings.warn(text, cls, stacklevel=stacklevel+1)
status_reasons = {