summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBert JW Regeer <bertjw@regeer.org>2020-01-21 20:52:49 -0800
committerBert JW Regeer <bertjw@regeer.org>2020-01-21 20:52:49 -0800
commit77c67bc73301eee396fe3f96baed0435826cbebe (patch)
tree874af5da0c4f463bc64262920ace05dcb6c7b992
parent41a1ebe1f6a6f337188cce22280477d48f1b95bb (diff)
downloadwebob-1.8.6.tar.gz
Prep version 1.8.61.8.6
-rw-r--r--CHANGES.txt33
-rw-r--r--setup.py2
2 files changed, 34 insertions, 1 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 8ba864f..429fdd7 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,3 +1,36 @@
+1.8.6 (2020-01-21)
+------------------
+
+Experimental Features
+~~~~~~~~~~~~~~~~~~~~~
+
+- The SameSite value now includes a new option named "None", this is a new
+ change that was introduced in
+ https://tools.ietf.org/html/draft-west-cookie-incrementalism-00
+
+ Please be aware that older clients are incompatible with this change:
+ https://www.chromium.org/updates/same-site/incompatible-clients, WebOb does
+ not enable SameSite on cookies by default, so there is no backwards
+ incompatible change here.
+
+ See https://github.com/Pylons/webob/issues/406
+
+- Validation of SameSite values can be disabled by toggling a module flag. This
+ is in anticipation of future changes in evolving cookie standards.
+ The discussion in https://github.com/Pylons/webob/pull/407 (which initially
+ expanded the allowed options) notes the sudden change to browser cookie
+ implementation details may happen again.
+
+ In May 2019, Google announced a new model for privacy controls in their
+ browsers, which affected the list of valid options for the SameSite attribute
+ of cookies. In late 2019, the company began to roll out these changes to their
+ browsers to force developer adoption of the new specification.
+ See https://www.chromium.org/updates/same-site and
+ https://blog.chromium.org/2019/10/developers-get-ready-for-new.html for more
+ details on this change.
+
+ See https://github.com/Pylons/webob/pull/409
+
1.8.5 (2019-01-03)
------------------
diff --git a/setup.py b/setup.py
index 92ed7b6..cdd7496 100644
--- a/setup.py
+++ b/setup.py
@@ -25,7 +25,7 @@ docs_extras = [
setup(
name='WebOb',
- version='1.8.5',
+ version='1.8.6',
description="WSGI request and response object",
long_description=README + '\n\n' + CHANGES,
classifiers=[