summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBert JW Regeer <bertjw@regeer.org>2015-10-30 16:14:51 -0600
committerBert JW Regeer <bertjw@regeer.org>2015-10-30 16:14:51 -0600
commitb1ad7a8838583679518840b06fd7ce8025622bac (patch)
tree300fff21bfd00311088840497c8b6955eb0854c7
parentaf0cdd6af135f95d96dda6b19829fe770cb17f2a (diff)
downloadwebob-1.5.1.tar.gz
Prep 1.5.1 release1.5.1
-rw-r--r--CHANGES.txt4
-rw-r--r--docs/whatsnew-1.5.txt9
-rw-r--r--setup.py2
3 files changed, 12 insertions, 3 deletions
diff --git a/CHANGES.txt b/CHANGES.txt
index 139c04f..c28924f 100644
--- a/CHANGES.txt
+++ b/CHANGES.txt
@@ -1,5 +1,5 @@
-Unreleased
-----------
+1.5.1 (2015-10-30)
+------------------
Bug Fixes
~~~~~~~~~
diff --git a/docs/whatsnew-1.5.txt b/docs/whatsnew-1.5.txt
index ab1bb72..80f5585 100644
--- a/docs/whatsnew-1.5.txt
+++ b/docs/whatsnew-1.5.txt
@@ -56,6 +56,15 @@ Features
Bug Fixes
~~~~~~~~~
+- The exceptions HTTPNotAcceptable, HTTPUnsupportedMediaType and
+ HTTPNotImplemented will now correctly use the sub-classed template rather
+ than the default error template. See https://github.com/Pylons/webob/issues/221
+
+- Response's from_file now correctly deals with a status line that contains an
+ HTTP version identifier. HTTP/1.1 200 OK is now correctly parsed, whereas
+ before this would raise an error upon setting the Response.status in
+ from_file. See https://github.com/Pylons/webob/issues/121
+
- The cookie API functions will now make sure that `max_age` is an integer or
an string that can convert to an integer. Previously passing in
max_age='test' would have silently done the wrong thing.
diff --git a/setup.py b/setup.py
index 8c49597..9fe6f2b 100644
--- a/setup.py
+++ b/setup.py
@@ -23,7 +23,7 @@ docs_extras = [
setup(
name='WebOb',
- version='1.5.0',
+ version='1.5.1',
description="WSGI request and response object",
long_description=README + '\n\n' + CHANGES,
classifiers=[