summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBert JW Regeer <bertjw@regeer.org>2023-01-22 21:12:17 -0700
committerGitHub <noreply@github.com>2023-01-22 21:12:17 -0700
commitc0dda6a40b6fd5dd90f7d6c61556cb489ac2b4e8 (patch)
tree277700f4b920c7fe252a0e4d3dbbdd6c7f46ec85
parent2df6d0cefadc781da3c098af06a912c1a87a9958 (diff)
parent434db9c05d33ec109d6d8b0eabc6f8dadad26f0d (diff)
downloadwebob-main.tar.gz
Merge pull request #447 from miketheman/miketheman/testsHEADmain
Test against Python 3.11
-rw-r--r--.github/workflows/ci-tests.yml1
-rw-r--r--setup.py1
-rw-r--r--tox.ini2
3 files changed, 3 insertions, 1 deletions
diff --git a/.github/workflows/ci-tests.yml b/.github/workflows/ci-tests.yml
index d934f9a..09b68c8 100644
--- a/.github/workflows/ci-tests.yml
+++ b/.github/workflows/ci-tests.yml
@@ -20,6 +20,7 @@ jobs:
- "3.8"
- "3.9"
- "3.10"
+ - "3.11"
- "pypy-3.8"
os:
- "ubuntu-latest"
diff --git a/setup.py b/setup.py
index 2b63ca2..3cf1177 100644
--- a/setup.py
+++ b/setup.py
@@ -37,6 +37,7 @@ setup(
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
"Programming Language :: Python :: Implementation :: CPython",
"Programming Language :: Python :: Implementation :: PyPy",
],
diff --git a/tox.ini b/tox.ini
index d9b2c14..1c13b53 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,7 +1,7 @@
[tox]
envlist =
lint,
- py37,py38,py39,py310,pypy3,
+ py37,py38,py39,py310,py311,pypy3,
docs,
coverage
isolated_build = True