summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlec Thomas <alec@swapoff.org>2018-07-27 19:01:31 +1000
committerAlec Thomas <alec@swapoff.org>2018-07-27 19:01:31 +1000
commit7bcc56cbfff29fe3c10268c99b4b9c598f74fc4d (patch)
treece4332c38c2a95b42684fd3d2448b587045690b9
parentcbb7ae763f8fc6184cff8bd32c5ae3645ec69f82 (diff)
downloadvoluptuous-0.11.3.tar.gz
0.11.30.11.3
-rw-r--r--setup.py15
-rw-r--r--voluptuous/__init__.py2
2 files changed, 6 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 41db631..52e0079 100644
--- a/setup.py
+++ b/setup.py
@@ -9,16 +9,11 @@ import atexit
sys.path.insert(0, '.')
version = __import__('voluptuous').__version__
-try:
- import pypandoc
- long_description = pypandoc.convert('README.md', 'rst')
- with open('README.rst', 'wb') as f:
- f.write(long_description.encode('utf-8'))
- atexit.register(lambda: os.unlink('README.rst'))
-except (ImportError, OSError):
- print('WARNING: Could not locate pandoc, using Markdown long_description.')
- with open('README.md') as f:
- long_description = f.read()
+import pypandoc
+long_description = pypandoc.convert('README.md', 'rst')
+with open('README.rst', 'wb') as f:
+ f.write(long_description.encode('utf-8'))
+atexit.register(lambda: os.unlink('README.rst'))
description = long_description.splitlines()[0].strip()
diff --git a/voluptuous/__init__.py b/voluptuous/__init__.py
index 4c052c6..80f5bf7 100644
--- a/voluptuous/__init__.py
+++ b/voluptuous/__init__.py
@@ -5,5 +5,5 @@ from voluptuous.validators import *
from voluptuous.util import *
from voluptuous.error import *
-__version__ = '0.11.2'
+__version__ = '0.11.3'
__author__ = 'alecthomas'