summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorroberto@sirius <roberto@sirius>2010-05-01 08:04:05 +0200
committerroberto@sirius <roberto@sirius>2010-05-01 08:04:05 +0200
commit0d5857a1bc2ebd68867e2667f0b63a705100f444 (patch)
treea29c21463db3e80e190a90e84450248acabe0cff /setup.py
parente3a51be1f987a8b9994e65585e998d39734ed485 (diff)
downloaduwsgi-0d5857a1bc2ebd68867e2667f0b63a705100f444.tar.gz
pip hack [4]
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index bdb83260..254d0c90 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@ class uWSGIBuilder(build_ext):
class uWSGIInstall(install):
def run(self):
- self.distribution.cmdclass['orig_install'].run()
+ print self.record
uc.parse_vars()
uc.build_uwsgi(sys.prefix + '/bin/' + uc.UWSGI_BIN_NAME)
@@ -26,7 +26,6 @@ class uWSGIDistribution(Distribution):
def __init__(self, *attrs):
Distribution.__init__(self, *attrs)
- self.cmdclass['orig_install'] = self.cmdclass['install']
self.cmdclass['install'] = uWSGIInstall
self.cmdclass['build_ext'] = uWSGIBuilder