summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorIan Ward <none@none>2009-11-04 18:27:03 -0500
committerIan Ward <none@none>2009-11-04 18:27:03 -0500
commitc302a54612c8c7dea8eaefbc61e527485a732dd8 (patch)
tree4a1df24c6d51dbd16dc4e4fbe00eacfae1ba9dfd /setup.py
parentb4c573e877b45b273be71ceff0df575e5f90856f (diff)
downloadurwid-c302a54612c8c7dea8eaefbc61e527485a732dd8.tar.gz
untab setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py64
1 files changed, 32 insertions, 32 deletions
diff --git a/setup.py b/setup.py
index fabd63b..d6a5034 100644
--- a/setup.py
+++ b/setup.py
@@ -20,10 +20,10 @@
# Urwid web site: http://excess.org/urwid/
try:
- from setuptools import setup, Extension
+ from setuptools import setup, Extension
have_setuptools = True
except ImportError:
- from distutils.core import setup, Extension
+ from distutils.core import setup, Extension
have_setuptools = False
import os
@@ -32,21 +32,21 @@ import urwid
release = urwid.__version__
setup_d = {
- 'name':"urwid",
- 'version':release,
- 'author':"Ian Ward",
- 'author_email':"ian@excess.org",
- 'ext_modules':[Extension('urwid.str_util', sources=['source/str_util.c'])],
- 'url':"http://excess.org/urwid/",
- 'download_url':"http://excess.org/urwid/urwid-%s.tar.gz"%release,
- 'license':"LGPL",
- 'keywords':"curses ui widget scroll listbox user interface text layout consolt ncurses",
- 'platforms':"unix-like",
- 'description':(
+ 'name':"urwid",
+ 'version':release,
+ 'author':"Ian Ward",
+ 'author_email':"ian@excess.org",
+ 'ext_modules':[Extension('urwid.str_util', sources=['source/str_util.c'])],
+ 'url':"http://excess.org/urwid/",
+ 'download_url':"http://excess.org/urwid/urwid-%s.tar.gz"%release,
+ 'license':"LGPL",
+ 'keywords':"curses ui widget scroll listbox user interface text layout consolt ncurses",
+ 'platforms':"unix-like",
+ 'description':(
"A console UI library featuring fluid interface resizing, UTF-8 support,"
" multiple text layouts, simple attribute markup, powerful scrolling list"
" boxes and flexible interface design."),
- 'long_description':"""
+ 'long_description':"""
Urwid is a console user interface library. It includes many features
useful for text console application developers including:
@@ -70,19 +70,19 @@ Home Page:
Example Program Screenshots:
http://excess.org/urwid/examples.html
"""[1:],
- 'classifiers':[
- "Development Status :: 4 - Beta",
- "Environment :: Console",
- "Environment :: Console :: Curses",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)",
- "Operating System :: POSIX",
- "Operating System :: Unix",
- "Operating System :: MacOS :: MacOS X",
- "Topic :: Software Development :: Libraries :: Python Modules",
- "Topic :: Software Development :: Widget Sets",
- ],
- 'packages':['urwid'],
+ 'classifiers':[
+ "Development Status :: 4 - Beta",
+ "Environment :: Console",
+ "Environment :: Console :: Curses",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: GNU Library or Lesser General Public License (LGPL)",
+ "Operating System :: POSIX",
+ "Operating System :: Unix",
+ "Operating System :: MacOS :: MacOS X",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ "Topic :: Software Development :: Widget Sets",
+ ],
+ 'packages':['urwid'],
}
if have_setuptools:
@@ -90,12 +90,12 @@ if have_setuptools:
try:
- True
+ True
except:
- # python 2.1's distutils doesn't understand these:
- del setup_d['classifiers']
- del setup_d['download_url']
+ # python 2.1's distutils doesn't understand these:
+ del setup_d['classifiers']
+ del setup_d['download_url']
if __name__ == "__main__":
- setup( ** setup_d )
+ setup( ** setup_d )