summaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorAlexey Stepanov <penguinolog@users.noreply.github.com>2023-04-25 19:20:33 +0200
committerGitHub <noreply@github.com>2023-04-25 19:20:33 +0200
commit1cc1d63358f7759785b39079eca069ed41078b6d (patch)
tree80261451a20ea64dac2185060908668a97b15f36 /pyproject.toml
parent6bf74be23f3179d87d4f40d45d2a4e8718ab26f5 (diff)
downloadurwid-1cc1d63358f7759785b39079eca069ed41078b6d.tar.gz
Fix incorrect type cast in vterm (`apply_mapping` should return `bytes`) (#545)
* Fix incorrect type cast in vterm (`apply_mapping` should return `bytes`) Add `time.sleep(0.1)` to the event loop tests: in the worst scenario on windows and slow machine function in parallel thread/async can wait up to 80 milliseconds (tested) Add type annotations to the `vterm` and `test_vterm` to simplify error lookup. * Fix `DeprecationWarning` in doctests & examples * Add `pytest` configuration in `pyproject.toml` without migration * `Signals.emit()` rework: stop `user_args` join with `weak_args` Partial: #544 Partial: #512 Partial: #406 * drop `sleep`: not enough effective with pytest * set timer for errors raise to 0: faster raise, faster test done --------- Co-authored-by: Aleksei Stepanov <alekseis@nvidia.com>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml6
1 files changed, 6 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index ca21353..a417089 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -49,6 +49,12 @@ universal = 0
profile = "black"
line_length = 120
+[tool.pytest.ini_options]
+minversion = "6.0"
+addopts = "-vvvv --doctest-modules -s --cov=urwid"
+doctest_optionflags = ["ELLIPSIS", "IGNORE_EXCEPTION_DETAIL"]
+testpaths = ["urwid"]
+
[tool.coverage.run]
omit = ["urwid/tests/*", ".tox/*", "setup.py"]
branch = true