summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Stepanov <penguinolog@users.noreply.github.com>2023-03-28 22:02:15 +0200
committerGitHub <noreply@github.com>2023-03-28 22:02:15 +0200
commitbc43d926e1fc339d9a07ecd1d0919f83f311c09a (patch)
tree1cdb559b92bc316f5920b7776fed9e5730868d99
parentc3ca1affc41db182873b6e98841def6213ad12d4 (diff)
downloadurwid-bc43d926e1fc339d9a07ecd1d0919f83f311c09a.tar.gz
Initial GitHub actions support (#523)
Co-authored-by: Aleksei Stepanov <alekseis@nvidia.com>
-rw-r--r--.github/workflows/pythonpackage.yml29
1 files changed, 29 insertions, 0 deletions
diff --git a/.github/workflows/pythonpackage.yml b/.github/workflows/pythonpackage.yml
new file mode 100644
index 0000000..069803e
--- /dev/null
+++ b/.github/workflows/pythonpackage.yml
@@ -0,0 +1,29 @@
+name: Python package
+
+on: [push, pull_request]
+
+jobs:
+ Test:
+ runs-on: ${{ matrix.os }}
+ strategy:
+ max-parallel: 6
+ matrix:
+ os: [ "ubuntu-latest"] # , "windows-latest" # enable windows after Windows driver will be added
+ python-version: [ "3.7", "3.8", "3.9", "3.10", "3.11" ]
+
+ steps:
+ - uses: actions/checkout@v3.5.0
+ - name: Set up Python ${{ matrix.python-version }}
+ uses: actions/setup-python@v4.5.0
+ with:
+ python-version: ${{ matrix.python-version }}
+ - name: Install dependencies
+ run: |
+ python -m pip install --upgrade pip wheel
+ pip install twisted trio "tornado<5.0.0" coverage
+ - name: Test
+ run: |
+ coverage run ./setup.py test
+ coverage report
+# - name: Coveralls
+# uses: coverallsapp/github-action@v1 \ No newline at end of file