summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTamas Nepusz <ntamas@gmail.com>2019-10-24 14:29:48 +0200
committerTamas Nepusz <ntamas@gmail.com>2019-10-24 14:29:48 +0200
commit59cb9ca41f1ec218f4e045874800fcbedc0b993b (patch)
treef5b17668f4570e175968226bfe1755bf63c97378
parenta02f7e6c68b04d22780d14611510d1387682908a (diff)
downloadurwid-59cb9ca41f1ec218f4e045874800fcbedc0b993b.tar.gz
ensure that TrioEventLoop is not needed on Python 3.4 and older
-rw-r--r--tox.ini1
-rw-r--r--urwid/__init__.py6
2 files changed, 5 insertions, 2 deletions
diff --git a/tox.ini b/tox.ini
index 48d37b9..981099b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -22,7 +22,6 @@ deps =
py35: trio
py36: trio
py37: trio
- pypy: trio
# NOTE: py34 is tested without Trio; Trio is not supported on Py < 3.5.
commands =
coverage run ./setup.py test
diff --git a/urwid/__init__.py b/urwid/__init__.py
index 192f0e9..3eb4e99 100644
--- a/urwid/__init__.py
+++ b/urwid/__init__.py
@@ -55,11 +55,15 @@ from urwid.command_map import (CommandMap, command_map,
CURSOR_PAGE_UP, CURSOR_PAGE_DOWN, CURSOR_MAX_LEFT, CURSOR_MAX_RIGHT,
ACTIVATE)
from urwid.main_loop import (ExitMainLoop, MainLoop, SelectEventLoop,
- GLibEventLoop, TornadoEventLoop, AsyncioEventLoop, TrioEventLoop)
+ GLibEventLoop, TornadoEventLoop, AsyncioEventLoop)
try:
from urwid.main_loop import TwistedEventLoop
except ImportError:
pass
+try:
+ from urwid.main_loop import TrioEventLoop
+except ImportError:
+ pass
from urwid.text_layout import (TextLayout, StandardTextLayout, default_layout,
LayoutSegment)
from urwid.display_common import (UPDATE_PALETTE_ENTRY, DEFAULT, BLACK,