summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Dunai <andunai@gmail.com>2018-01-17 13:23:50 +0200
committerAndrew Dunai <andunai@gmail.com>2018-01-17 13:23:50 +0200
commitd63c8f942ce7c45b62f531ba919f246d6556496c (patch)
treebfb81e884f179c40c8f852572180afc056f2b9e4
parent56f80736c1f6f8ab35a94a4e1b4077d2ad78c0c4 (diff)
downloadurwid-hashbang-env.tar.gz
Proper hashbangs by douglas-larocca, closes #137hashbang-env
-rw-r--r--examples/asyncio_socket_server.py1
-rwxr-xr-xexamples/bigtext.py2
-rwxr-xr-xexamples/browse.py2
-rwxr-xr-xexamples/calc.py2
-rwxr-xr-xexamples/dialog.py2
-rwxr-xr-xexamples/edit.py2
-rwxr-xr-xexamples/fib.py2
-rwxr-xr-xexamples/graph.py2
-rwxr-xr-xexamples/input_test.py2
-rwxr-xr-xexamples/lcd_cf635.py2
-rwxr-xr-xexamples/palette_test.py2
-rwxr-xr-xexamples/pop_up.py2
-rwxr-xr-xexamples/subproc.py2
-rw-r--r--examples/subproc2.py1
-rwxr-xr-xexamples/terminal.py2
-rwxr-xr-xexamples/tour.py2
-rwxr-xr-xexamples/treesample.py2
-rw-r--r--examples/twisted_serve_ssh.py1
-rw-r--r--setup.py2
19 files changed, 18 insertions, 17 deletions
diff --git a/examples/asyncio_socket_server.py b/examples/asyncio_socket_server.py
index 87592d3..31c9e81 100644
--- a/examples/asyncio_socket_server.py
+++ b/examples/asyncio_socket_server.py
@@ -1,3 +1,4 @@
+#!/usr/bin/env python
"""Demo of using urwid with Python 3.4's asyncio.
This code works on older Python 3.x if you install `asyncio` from PyPI, and
diff --git a/examples/bigtext.py b/examples/bigtext.py
index 8fc448c..6a088ea 100755
--- a/examples/bigtext.py
+++ b/examples/bigtext.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Urwid BigText example program
# Copyright (C) 2004-2009 Ian Ward
diff --git a/examples/browse.py b/examples/browse.py
index ab689c0..6c0eb37 100755
--- a/examples/browse.py
+++ b/examples/browse.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Urwid example lazy directory browser / tree view
# Copyright (C) 2004-2011 Ian Ward
diff --git a/examples/calc.py b/examples/calc.py
index e56be4a..39c37f7 100755
--- a/examples/calc.py
+++ b/examples/calc.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Urwid advanced example column calculator application
# Copyright (C) 2004-2009 Ian Ward
diff --git a/examples/dialog.py b/examples/dialog.py
index 1328e79..b444280 100755
--- a/examples/dialog.py
+++ b/examples/dialog.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Urwid example similar to dialog(1) program
# Copyright (C) 2004-2009 Ian Ward
diff --git a/examples/edit.py b/examples/edit.py
index e4fb4b0..e2cc2fa 100755
--- a/examples/edit.py
+++ b/examples/edit.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Urwid example lazy text editor suitable for tabbed and format=flowed text
# Copyright (C) 2004-2009 Ian Ward
diff --git a/examples/fib.py b/examples/fib.py
index ad6acc5..875c8fc 100755
--- a/examples/fib.py
+++ b/examples/fib.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Urwid example fibonacci sequence viewer / unbounded data demo
# Copyright (C) 2004-2007 Ian Ward
diff --git a/examples/graph.py b/examples/graph.py
index 536fa00..4a5b5dd 100755
--- a/examples/graph.py
+++ b/examples/graph.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Urwid graphics example program
# Copyright (C) 2004-2011 Ian Ward
diff --git a/examples/input_test.py b/examples/input_test.py
index 2c154bc..0a8eed9 100755
--- a/examples/input_test.py
+++ b/examples/input_test.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Urwid keyboard input test app
# Copyright (C) 2004-2009 Ian Ward
diff --git a/examples/lcd_cf635.py b/examples/lcd_cf635.py
index 09f66ef..0377233 100755
--- a/examples/lcd_cf635.py
+++ b/examples/lcd_cf635.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
"""
The crystalfontz 635 has these characters in ROM:
diff --git a/examples/palette_test.py b/examples/palette_test.py
index 820feb5..0c98623 100755
--- a/examples/palette_test.py
+++ b/examples/palette_test.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Urwid Palette Test. Showing off highcolor support
# Copyright (C) 2004-2009 Ian Ward
diff --git a/examples/pop_up.py b/examples/pop_up.py
index 37e2258..f88c717 100755
--- a/examples/pop_up.py
+++ b/examples/pop_up.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
import urwid
diff --git a/examples/subproc.py b/examples/subproc.py
index 4c7e918..f04e7b0 100755
--- a/examples/subproc.py
+++ b/examples/subproc.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
import subprocess
import urwid
diff --git a/examples/subproc2.py b/examples/subproc2.py
index c40a647..a60aa72 100644
--- a/examples/subproc2.py
+++ b/examples/subproc2.py
@@ -1,3 +1,4 @@
+#!/usr/bin/env python
# this is part of the subproc.py example
from __future__ import print_function
diff --git a/examples/terminal.py b/examples/terminal.py
index 18edba1..ff30a93 100755
--- a/examples/terminal.py
+++ b/examples/terminal.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Urwid terminal emulation widget example app
# Copyright (C) 2010 aszlig
diff --git a/examples/tour.py b/examples/tour.py
index fedfb59..cf04da2 100755
--- a/examples/tour.py
+++ b/examples/tour.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Urwid tour. It slices, it dices..
# Copyright (C) 2004-2011 Ian Ward
diff --git a/examples/treesample.py b/examples/treesample.py
index f6f771d..7b4f42f 100755
--- a/examples/treesample.py
+++ b/examples/treesample.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Trivial data browser
# This version:
diff --git a/examples/twisted_serve_ssh.py b/examples/twisted_serve_ssh.py
index c1a0004..b2e0206 100644
--- a/examples/twisted_serve_ssh.py
+++ b/examples/twisted_serve_ssh.py
@@ -1,4 +1,3 @@
-# encoding: utf-8
"""
Twisted integration for Urwid.
diff --git a/setup.py b/setup.py
index 37a7413..60fdb02 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,4 @@
-#!/usr/bin/python
+#!/usr/bin/env python
#
# Urwid setup.py exports the useful bits
# Copyright (C) 2004-2014 Ian Ward