summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndrey Petrov <andrey.petrov@shazow.net>2009-12-10 21:33:08 -0800
committerAndrey Petrov <andrey.petrov@shazow.net>2009-12-10 21:33:08 -0800
commitc73bf7c7ba0051cd3e52f2d4760322f62800a736 (patch)
tree1fd2d042fb6c1c0646585d36c569ec41d2abfb11 /setup.py
downloadurllib3-c73bf7c7ba0051cd3e52f2d4760322f62800a736.tar.gz
Initial import of source.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py27
1 files changed, 27 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..a0a66c3f
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,27 @@
+from setuptools import setup, find_packages
+import sys, os
+
+version = '0.2'
+
+long_description = open('README.txt').read()
+
+setup(name='urllib3',
+ version=version,
+ description="HTTP library with thread-safe connection pooling and file post support",
+ long_description=long_description,
+ classifiers=[], # Get strings from http://pypi.python.org/pypi?%3Aaction=list_classifiers
+ keywords='urllib httplib threadsafe filepost http',
+ author='Andrey Petrov',
+ author_email='andrey.petrov@shazow.net',
+ url='http://code.google.com/p/urllib3/',
+ license='MIT',
+ packages=find_packages(exclude=['ez_setup', 'tests']),
+ include_package_data=True,
+ zip_safe=False,
+ install_requires=[
+ # -*- Extra requirements: -*-
+ ],
+ entry_points="""
+ # -*- Entry points: -*-
+ """,
+ )