summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorAndrey Petrov <andrey.petrov@shazow.net>2011-09-21 12:59:12 -0700
committerAndrey Petrov <andrey.petrov@shazow.net>2011-09-21 12:59:12 -0700
commitbad03705c84ffd06ff7663c8890ebb9d5dac9241 (patch)
tree1334ce43387f3e97689dab61cf30b44e5b4a2a87 /setup.py
parent174652f755c15056a74643aac8a3cbd4f68fbc0b (diff)
downloadurllib3-bad03705c84ffd06ff7663c8890ebb9d5dac9241.tar.gz
Modernizing setup.py
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py21
1 files changed, 11 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 1ae5c6be..23f1d240 100644
--- a/setup.py
+++ b/setup.py
@@ -1,4 +1,13 @@
-from setuptools import setup, find_packages
+#!/usr/bin/env python
+
+from distutils.core import setup
+
+
+try:
+ import setuptools
+except ImportError, _:
+ pass # No 'develop' command, oh well.
+
version = '0.5'
@@ -23,13 +32,5 @@ setup(name='urllib3',
url='http://code.google.com/p/urllib3/',
download_url='http://urllib3.googlecode.com/files/urllib3-0.5.tar.gz',
license='MIT',
- packages=find_packages(exclude=['ez_setup', 'tests']),
- include_package_data=True,
- zip_safe=False,
- install_requires=[
- # -*- Extra requirements: -*-
- ],
- entry_points="""
- # -*- Entry points: -*-
- """,
+ packages=['urllib3'],
)