summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSascha Peilicke <saschpe@mailbox.org>2014-03-20 15:41:39 +0100
committerSascha Peilicke <saschpe@mailbox.org>2014-03-20 15:41:39 +0100
commit3361f884456699c67bf4eef2eeafb14a071cc509 (patch)
tree92550a052da8e3d2c49bfd967e2eeb2285cc22fb /setup.py
parentd42cf444eb7b39aaf4f4f0afbb83266950458f37 (diff)
downloadurllib3-3361f884456699c67bf4eef2eeafb14a071cc509.tar.gz
Don't install dummyserver into site-packages
It is pure example code with self-signed certificates. It pollutes the global site-packages spaces and is potentially dangerous (if used accidentally). It doesn't make sense to install it as 'package_data' or 'date_files' either. Since it servers as an example it should be part of the source distribution.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 392b885d..84e6d5ff 100644
--- a/setup.py
+++ b/setup.py
@@ -44,7 +44,7 @@ setup(name='urllib3',
author_email='andrey.petrov@shazow.net',
url='http://urllib3.readthedocs.org/',
license='MIT',
- packages=['urllib3', 'dummyserver',
+ packages=['urllib3',
'urllib3.packages', 'urllib3.packages.ssl_match_hostname',
'urllib3.contrib',
],