summaryrefslogtreecommitdiff
path: root/ci
diff options
context:
space:
mode:
authorIan Stapleton Cordasco <graffatcolmingov@gmail.com>2021-12-30 15:33:43 -0600
committerGitHub <noreply@github.com>2021-12-30 15:33:43 -0600
commitc96cf403fb4f24d414f40faf4691174e4c54ea0b (patch)
tree7125d5a797e6172e024e3d0f559c402f100aaf04 /ci
parentd4c25791cd5002a5234d882a28040db94ca38595 (diff)
downloadurllib3-c96cf403fb4f24d414f40faf4691174e4c54ea0b.tar.gz
Use pypa/build to build dists, remove duplicate Python setup step
We don't need to set things up twice in a row (which we were doing in restoring the cache) and let's use pypa/build instead of python setup.py since that's better supported and the future
Diffstat (limited to 'ci')
-rwxr-xr-xci/deploy.sh4
1 files changed, 2 insertions, 2 deletions
diff --git a/ci/deploy.sh b/ci/deploy.sh
index 503f0723..322ca26f 100755
--- a/ci/deploy.sh
+++ b/ci/deploy.sh
@@ -2,6 +2,6 @@
set -exo pipefail
-python3 -m pip install --upgrade twine wheel
-python3 setup.py sdist bdist_wheel
+python3 -m pip install --upgrade twine wheel build
+python3 -m build
python3 -m twine upload dist/* -u $PYPI_USERNAME -p $PYPI_PASSWORD --skip-existing