summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSeth Michael Larson <sethmichaellarson@gmail.com>2019-06-24 20:42:44 -0500
committerGitHub <noreply@github.com>2019-06-24 20:42:44 -0500
commitcdfc9a539cc27f5704f8bcd46d34301b3d218aff (patch)
tree26845636aec104fe69c29a5c77621927944dc2ce /Makefile
parentc02698afebfaf057003d0d9e7f53e5dca419ed58 (diff)
downloadurllib3-cdfc9a539cc27f5704f8bcd46d34301b3d218aff.tar.gz
Remove the Makefile as it's not maintained (#1629)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile70
1 files changed, 0 insertions, 70 deletions
diff --git a/Makefile b/Makefile
deleted file mode 100644
index e62952bd..00000000
--- a/Makefile
+++ /dev/null
@@ -1,70 +0,0 @@
-REQUIREMENTS_FILE=dev-requirements.txt
-REQUIREMENTS_OUT=dev-requirements.txt.log
-SETUP_OUT=*.egg-info
-
-.PHONY: all
-all: setup requirements
-
-.PHONY: virtualenv
-virtualenv:
-ifndef VIRTUAL_ENV
- $(error Must be run inside of a virtualenv)
-endif
-
-.PHONY: setup
-setup: virtualenv $(SETUP_OUT)
-
-.PHONY: $(SETUP_OUT)
-$(SETUP_OUT): setup.py setup.cfg
- python setup.py develop
- touch $(SETUP_OUT)
-
-.PHONY: requirements
-requirements: setup $(REQUIREMENTS_OUT)
-
-.PHONY: piprot
-piprot: setup
- pip install piprot
- piprot -x $(REQUIREMENTS_FILE)
-
-.PHONY: $(REQUIREMENTS_OUT)
-$(REQUIREMENTS_OUT): $(REQUIREMENTS_FILE)
- pip install -r $(REQUIREMENTS_FILE) | tee -a $(REQUIREMENTS_OUT)
- python setup.py develop
-
-.PHONY: clean
-clean:
- find . -name "*.py[oc]" -delete
- find . -name "__pycache__" -delete
- rm -f $(REQUIREMENTS_OUT)
- rm -rf docs/_build build/ dist/
-
-.PHONY: test
-test: requirements
- tox
-
-.PHONY: test-quick
-test-quick: requirements
- tox -e py36
- tox -e py27
-
-.PHONY: test-all
-test-all: requirements
- tox
-
-.PHONY: test-gae
-test-gae: requirements
-ifndef GAE_PYTHONPATH
- $(error GAE_PYTHONPATH must be set)
-endif
- tox -e gae
-
-.PHONY: docs
-docs:
- tox -e docs
-
-.PHONY: release
-release:
- ./release.sh
-
-