summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorGuido van Rossum <guido@python.org>2014-05-19 11:22:12 -0700
committerGuido van Rossum <guido@python.org>2014-05-19 11:22:12 -0700
commit90f64c2975a6c3cabadbe03256d07ebe74d88911 (patch)
tree4a4db93c18beeea35695cb0685ffe5e49b98067c /Makefile
parent3c0d240f882dc81bbdc07f1dd9306df29cf3afcb (diff)
downloadtrollius-90f64c2975a6c3cabadbe03256d07ebe74d88911.tar.gz
Update instructions for Windows.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 952c93f..eda02f2 100644
--- a/Makefile
+++ b/Makefile
@@ -42,9 +42,19 @@ clean:
rm -f MANIFEST
+# For distribution builders only!
# Push a source distribution for Python 3.3 to PyPI.
# You must update the version in setup.py first.
-# The corresponding action on Windows is pypi.bat.
-# A PyPI user configuration in ~/.pypirc is required.
+# A PyPI user configuration in ~/.pypirc is required;
+# you can create a suitable confifuration using
+# python setup.py register
pypi: clean
python3.3 setup.py sdist upload
+
+# The corresponding action on Windows is pypi.bat. For that to work,
+# you need to install wheel and setuptools. The easiest way is to get
+# pip using the get-pip.py script found here:
+# https://pip.pypa.io/en/latest/installing.html#install-pip
+# That will install setuptools and pip; then you can just do
+# \Python33\python.exe -m pip install wheel
+# after which the pypi.bat script should work.