summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2014-12-18 12:36:40 +0100
committerVictor Stinner <victor.stinner@gmail.com>2014-12-18 12:36:40 +0100
commit0a99e5f2e2f1ae3d9e26a460fcb311e5f814f8f4 (patch)
tree76bb788fe33f0fb731d3d6e6b09ae432f6db7ab7
parent5fb15e5a4ba08dfa7a1985422578ca1da88eefdd (diff)
downloadtrollius-0a99e5f2e2f1ae3d9e26a460fcb311e5f814f8f4.tar.gz
Add tox.ini
-rw-r--r--.hgignore1
-rw-r--r--setup.py3
-rw-r--r--tox.ini11
3 files changed, 13 insertions, 2 deletions
diff --git a/.hgignore b/.hgignore
index 6d1136f..736c7fd 100644
--- a/.hgignore
+++ b/.hgignore
@@ -12,3 +12,4 @@ distribute-\d+.\d+.\d+.tar.gz$
build$
dist$
.*\.egg-info$
+\.tox$
diff --git a/setup.py b/setup.py
index 3a3a4db..87a629d 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,5 @@
# Release procedure:
-# - run unit tests with python 3.3 in debug mode
-# - run unit tests with python dev (3.5) in debug mode
+# - run tox (to run runtests.py and run_aiotest.py)
# - maybe test examples
# - update version in setup.py
# - hg ci
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..040b25a
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,11 @@
+[tox]
+envlist = py33,py34
+
+[testenv]
+deps=
+ aiotest
+setenv =
+ PYTHONASYNCIODEBUG = 1
+commands=
+ python runtests.py -r {posargs}
+ python run_aiotest.py -r {posargs}