summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py30
1 files changed, 22 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index fad16e7..011db09 100644
--- a/setup.py
+++ b/setup.py
@@ -1,14 +1,28 @@
import os
-from distutils.core import setup, Extension
+from setuptools import setup, Extension
extensions = []
if os.name == 'nt':
- ext = Extension('_overlapped', ['overlapped.c'], libraries=['ws2_32'])
+ ext = Extension(
+ 'asyncio._overlapped', ['overlapped.c'], libraries=['ws2_32'],
+ )
extensions.append(ext)
-setup(name='asyncio',
- description="reference implementation of PEP 3156",
- url='http://www.python.org/dev/peps/pep-3156/',
- packages=['asyncio'],
- ext_modules=extensions
- )
+setup(
+ name="asyncio",
+ version="0.1.1",
+
+ description="reference implementation of PEP 3156",
+ long_description=open("README").read(),
+ url="http://www.python.org/dev/peps/pep-3156/",
+
+ classifiers=[
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.3",
+ ],
+
+ packages=["asyncio"],
+
+ ext_modules=extensions,
+)