summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2018-03-09 11:08:10 +0100
committerVictor Stinner <victor.stinner@gmail.com>2018-03-09 11:08:10 +0100
commitfa13a1c0182840b72faa17078eb78c8b5e5f45c4 (patch)
treeb65409fd0dc6d4407032d097aebc7f91bb2f6dc6
parent97c56f0103fc581b191be74da3900f42ad090ca0 (diff)
downloadtrollius-git-fa13a1c0182840b72faa17078eb78c8b5e5f45c4.tar.gz
Prepare 2.2 releasetrollius-2.2
-rw-r--r--doc/changelog.rst16
-rw-r--r--setup.py8
2 files changed, 20 insertions, 4 deletions
diff --git a/doc/changelog.rst b/doc/changelog.rst
index 8c54c96..3170470 100644
--- a/doc/changelog.rst
+++ b/doc/changelog.rst
@@ -5,8 +5,20 @@ Change log
.. warning::
:ref:`The Trollius project is now deprecated! <deprecated>`
-Version 2.1
-===========
+Version 2.2 (2018-03-09)
+========================
+
+Changes:
+
+* ``run_aiotest.py`` has been removed since the ``aiotest`` project has been
+ removed
+* Add the "No Maintenance Intended" badge to README
+* The Trollius documentation is no longer online:
+ http://trollius.readthedocs.io/ has been removed
+* Update the GitHub URL to: https://github.com/vstinner/trollius
+
+Version 2.1 (2016-02-05)
+========================
Changes:
diff --git a/setup.py b/setup.py
index 64f14da..f68e143 100644
--- a/setup.py
+++ b/setup.py
@@ -1,5 +1,6 @@
# Prepare a release:
#
+# - git pull --rebase
# - fill trollius changelog
# - run maybe ./update-asyncio-step1.sh
# - run all tests on Linux: tox
@@ -17,15 +18,18 @@
#
# - git tag trollius-VERSION
# - git push --tags
-# - On Linux: python setup.py register sdist upload
+# - Remove untracked files/dirs: git clean -fdx
+# - On Linux: python2 setup.py sdist
# FIXME: don't use bdist_wheel because of
# FIXME: https://github.com/haypo/trollius/issues/1
+# - twine upload dist/*
# - On Windows: python releaser.py release
#
# After the release:
#
# - increment version in setup.py (version) and doc/conf.py (version, release)
-# - git commit -a && git push
+# - git commit -a -m "post release X.Y"
+# - git push
import os
import sys