summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <victor.stinner@gmail.com>2018-03-09 10:59:38 +0100
committerVictor Stinner <victor.stinner@gmail.com>2018-03-09 11:00:05 +0100
commitc6c86417fe40646181d0b1f7b7ee071de95798bc (patch)
tree570d0f72280965a2384d21787d4c70cd9ba2e651
parentb4bacc05d9455c84838c00044c65a430552a9445 (diff)
downloadtrollius-git-c6c86417fe40646181d0b1f7b7ee071de95798bc.tar.gz
Remove aiotest tests
-rw-r--r--MANIFEST.in2
-rw-r--r--doc/dev.rst3
-rw-r--r--run_aiotest.py14
-rw-r--r--tox.ini12
4 files changed, 3 insertions, 28 deletions
diff --git a/MANIFEST.in b/MANIFEST.in
index f3b496f..9dabbdc 100644
--- a/MANIFEST.in
+++ b/MANIFEST.in
@@ -1,7 +1,7 @@
include AUTHORS COPYING TODO.rst tox.ini
include Makefile
include overlapped.c pypi.bat
-include check.py runtests.py run_aiotest.py release.py
+include check.py runtests.py release.py
include update-asyncio-*.sh
include .travis.yml
include releaser.conf
diff --git a/doc/dev.rst b/doc/dev.rst
index a6a3fcd..a05179b 100644
--- a/doc/dev.rst
+++ b/doc/dev.rst
@@ -29,9 +29,6 @@ On Python older than 3.3, unit tests require the `mock
<https://pypi.python.org/pypi/mock>`_ module. Python 2.6 and 2.7 require also
`unittest2 <https://pypi.python.org/pypi/unittest2>`_.
-To run ``run_aiotest.py``, you need the `aiotest
-<https://pypi.python.org/pypi/aiotest>`_ test suite: ``pip install aiotest``.
-
Run tests on UNIX
-----------------
diff --git a/run_aiotest.py b/run_aiotest.py
deleted file mode 100644
index da13328..0000000
--- a/run_aiotest.py
+++ /dev/null
@@ -1,14 +0,0 @@
-import aiotest.run
-import sys
-import trollius
-if sys.platform == 'win32':
- from trollius.windows_utils import socketpair
-else:
- from socket import socketpair
-
-config = aiotest.TestConfig()
-config.asyncio = trollius
-config.socketpair = socketpair
-config.new_event_pool_policy = trollius.DefaultEventLoopPolicy
-config.call_soon_check_closed = True
-aiotest.run.main(config)
diff --git a/tox.ini b/tox.ini
index 5058dd8..f51177d 100644
--- a/tox.ini
+++ b/tox.ini
@@ -4,31 +4,28 @@ envlist = py27,py2_release,py2_no_ssl,py2_no_concurrent,py33,py34,py3_release,py
[testenv]
deps=
- aiotest
six
setenv =
TROLLIUSDEBUG = 1
commands=
python -Wd runtests.py -r {posargs}
- python -Wd run_aiotest.py -r {posargs}
[testenv:pyflakes2]
basepython = python2
deps=
pyflakes
commands=
- pyflakes trollius tests runtests.py check.py run_aiotest.py setup.py
+ pyflakes trollius tests runtests.py check.py setup.py
[testenv:pyflakes3]
basepython = python3
deps=
pyflakes
commands=
- pyflakes trollius tests runtests.py check.py run_aiotest.py setup.py
+ pyflakes trollius tests runtests.py check.py setup.py
[testenv:py26]
deps=
- aiotest
futures
mock==1.0.1
ordereddict
@@ -37,7 +34,6 @@ deps=
[testenv:py27]
deps=
- aiotest
futures
mock
six
@@ -47,7 +43,6 @@ deps=
# Run tests in release mode
basepython = python2
deps=
- aiotest
futures
mock
six
@@ -58,7 +53,6 @@ setenv =
[testenv:py2_no_ssl]
basepython = python2
deps=
- aiotest
futures
mock
six
@@ -69,7 +63,6 @@ commands=
[testenv:py2_no_concurrent]
basepython = python2
deps=
- aiotest
futures
mock
six
@@ -79,7 +72,6 @@ commands=
[testenv:py32]
deps=
- aiotest
mock
six