summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2019-07-29 12:19:48 -0500
committerJason Madden <jamadden@gmail.com>2019-07-29 12:19:48 -0500
commit6b843ec24315e9092447c667dcdeeb7ba1878aa4 (patch)
tree214942dedef71375b6bc0abe3a74b95d897386f5
parent85e055dfea4d02354e63935c1a20dfb2708444be (diff)
downloadtrollius-git-6b843ec24315e9092447c667dcdeeb7ba1878aa4.tar.gz
Nope, drop PyPy: It does not actually build.
-rw-r--r--appveyor.yml14
-rw-r--r--doc/changelog.rst7
-rw-r--r--setup.py2
3 files changed, 14 insertions, 9 deletions
diff --git a/appveyor.yml b/appveyor.yml
index ccb86e5..2848eec 100644
--- a/appveyor.yml
+++ b/appveyor.yml
@@ -9,11 +9,15 @@ environment:
PYTHON_ARCH: "32"
PYTHON_EXE: python
GWHEEL_ONLY: true
- - PYTHON: "C:\\pypy2.7-v7.1.0-win32"
- PYTHON_ID: "pypy"
- PYTHON_EXE: pypy
- PYTHON_VERSION: "2.7.x"
- PYTHON_ARCH: "32"
+ # PyPy 7.1 won't actually build the _overlapped extension:
+ # overlapped.c(92) : warning C4013: 'PyErr_SetExcFromWindowsErr' undefined; assuming extern returning int
+ # overlapped.c(92) : warning C4047: 'return' : 'PyObject *' differs in levels of indirection from 'int'
+ # overlapped.c(1166) : warning C4101: 'AddressObj' : unreferenced local variable
+ # - PYTHON: "C:\\pypy2.7-v7.1.0-win32"
+ # PYTHON_ID: "pypy"
+ # PYTHON_EXE: pypy
+ # PYTHON_VERSION: "2.7.x"
+ # PYTHON_ARCH: "32"
install:
# If there is a newer build queued for the same PR, cancel this one.
diff --git a/doc/changelog.rst b/doc/changelog.rst
index 710625a..f61ccda 100644
--- a/doc/changelog.rst
+++ b/doc/changelog.rst
@@ -5,13 +5,14 @@
.. warning::
:ref:`The Trollius project is now deprecated! <deprecated>`
-Version 2.3 (2019-07-29)
-========================
+Version 2.2.post1 (2019-07-29)
+==============================
This is a packaging-only release. It is intended to be the last
release.
-- Release Windows wheels.
+- Release Windows wheels for CPython 2.7.
+- Use ``python_requires`` to restrict installation to Python 2.7.
Version 2.2 (2018-03-09)
========================
diff --git a/setup.py b/setup.py
index 015b7e5..268f0fa 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@ if sys.version_info < (3,):
setup(
name="trollius",
- version="2.3",
+ version="2.2.post1",
license="Apache License 2.0",
author='Victor Stinner',
author_email='victor.stinner@gmail.com',