summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Stinner <vstinner@redhat.com>2016-02-05 13:26:19 +0100
committerVictor Stinner <vstinner@redhat.com>2016-02-05 13:28:19 +0100
commit2c7f6ac0a0c8ad584ecde846383d658e809c068a (patch)
tree6c17ace33553808ce1af7be36296a366607dd046
parent5641f314fbc11ba4c3360eb3ecea2c59d77ddb7c (diff)
downloadtrollius-git-2c7f6ac0a0c8ad584ecde846383d658e809c068a.tar.gz
set version to 2.1
-rw-r--r--doc/conf.py2
-rw-r--r--setup.py16
2 files changed, 13 insertions, 5 deletions
diff --git a/doc/conf.py b/doc/conf.py
index 0d3b8dd..46ec218 100644
--- a/doc/conf.py
+++ b/doc/conf.py
@@ -48,7 +48,7 @@ copyright = u'2014, Victor Stinner'
# built documents.
#
# The short X.Y version.
-version = release = '2.0.1'
+version = release = '2.1'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
diff --git a/setup.py b/setup.py
index 19d9670..2a3df46 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,9 @@
-# Release procedure:
+# Prepare a release:
+#
# - fill trollius changelog
# - run maybe ./update-asyncio-step1.sh
-# - run all tests: tox
+# - run all tests on Linux: tox
+# - run tests on Windows
# - test examples
# - check that "python setup.py sdist" contains all files tracked by
# the SCM (Mercurial): update MANIFEST.in if needed
@@ -9,13 +11,19 @@
# - update version in setup.py (version) and doc/conf.py (version, release)
# - set release date in doc/changelog.rst
# - git commit
+# - git push
+#
+# Release a new version:
+#
# - git tag trollius-VERSION
# - git push --tags
-# - git push
# - On Linux: python setup.py register sdist upload
# FIXME: don't use bdist_wheel because of
# FIXME: https://github.com/haypo/trollius/issues/1
# - On Windows: python releaser.py release
+#
+# After the release:
+#
# - increment version in setup.py (version) and doc/conf.py (version, release)
# - git commit -a && git push
@@ -48,7 +56,7 @@ if sys.version_info < (3,):
install_options = {
"name": "trollius",
- "version": "2.0.1",
+ "version": "2.1",
"license": "Apache License 2.0",
"author": 'Victor Stinner',
"author_email": 'victor.stinner@gmail.com',