summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2019-07-29 12:39:04 -0500
committerJason Madden <jamadden@gmail.com>2019-07-29 12:39:04 -0500
commit763ab3ab8560e389ccab0d3479a199ed4d37ecf2 (patch)
tree06b5d30c50203ed38b05e59b0d24bc104553a298
parente9bd97ce3ce08dbd287c5973527839406e1ed6c5 (diff)
downloadtrollius-git-trollius-2.1.post1.tar.gz
Update README to indicate no maintenance.trollius-2.1.post1
-rw-r--r--README.rst49
-rw-r--r--setup.py8
2 files changed, 14 insertions, 43 deletions
diff --git a/README.rst b/README.rst
index a1bf495..79764d3 100644
--- a/README.rst
+++ b/README.rst
@@ -1,42 +1,11 @@
-Trollius provides infrastructure for writing single-threaded concurrent
-code using coroutines, multiplexing I/O access over sockets and other
-resources, running network clients and servers, and other related primitives.
-Here is a more detailed list of the package contents:
+========
+Trollius
+========
-* a pluggable event loop with various system-specific implementations;
+.. image:: http://unmaintained.tech/badge.svg
+ :target: http://unmaintained.tech/
+ :alt: No Maintenance Intended
-* transport and protocol abstractions (similar to those in `Twisted
- <http://twistedmatrix.com/>`_);
-
-* concrete support for TCP, UDP, SSL, subprocess pipes, delayed calls, and
- others (some may be system-dependent);
-
-* a ``Future`` class that mimics the one in the ``concurrent.futures`` module,
- but adapted for use with the event loop;
-
-* coroutines and tasks based on generators (``yield``), to help write
- concurrent code in a sequential fashion;
-
-* cancellation support for ``Future``\s and coroutines;
-
-* synchronization primitives for use between coroutines in a single thread,
- mimicking those in the ``threading`` module;
-
-* an interface for passing work off to a threadpool, for times when you
- absolutely, positively have to use a library that makes blocking I/O calls.
-
-Trollius is a portage of the `asyncio project
-<https://github.com/python/asyncio>`_ (`PEP 3156
-<http://legacy.python.org/dev/peps/pep-3156/>`_) on Python 2. Trollius works on
-Python 2.6-3.5. It has been tested on Windows, Linux, Mac OS X, FreeBSD and
-OpenIndiana.
-
-* `Asyncio documentation <http://docs.python.org/dev/library/asyncio.html>`_
-* `Trollius documentation <http://trollius.readthedocs.org/>`_
-* `Trollius project in the Python Cheeseshop (PyPI)
- <https://pypi.python.org/pypi/trollius>`_
-* `Trollius project at Github <https://github.com/haypo/trollius>`_
- (bug tracker, source code)
-* Copyright/license: Open source, Apache 2.0. Enjoy!
-
-See also the `asyncio project at Github <https://github.com/python/asyncio>`_.
+.. warning::
+ The Trollius project is deprecated and unsupported. It is on PyPI
+ to support existing dependencies only.
diff --git a/setup.py b/setup.py
index eaae3c6..542bd56 100644
--- a/setup.py
+++ b/setup.py
@@ -56,18 +56,18 @@ if sys.version_info < (3,):
install_options = {
"name": "trollius",
- "version": "2.1.post1",
+ "version": "2.1.post2",
"license": "Apache License 2.0",
"author": 'Victor Stinner',
"author_email": 'victor.stinner@gmail.com',
"description": "Port of the Tulip project (asyncio module, PEP 3156) on Python 2",
"long_description": long_description,
- "url": "https://github.com/haypo/trollius",
+ "url": "https://github.com/jamadden/trollius",
"classifiers": [
"Programming Language :: Python",
- "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 2.7",
"License :: OSI Approved :: Apache Software License",
],
@@ -75,6 +75,8 @@ install_options = {
"test_suite": "runtests.runtests",
"ext_modules": extensions,
+ "zip_safe": False,
+ "keywords": "unmaintained deprecated",
}
if SETUPTOOLS:
install_options['install_requires'] = requirements