summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Madden <jamadden@gmail.com>2019-07-30 09:35:18 -0500
committerJason Madden <jamadden@gmail.com>2019-07-30 09:35:18 -0500
commit4a940cd02a4f17a2974cec9901b4bc540a6fd6f7 (patch)
tree15c6d37fd2b9b6519502b4dbeabf00a668bfd257
parent9452a9918a51e940a22e5c95402173740baaef1b (diff)
downloadtrollius-git-1.0.4.tar.gz
Update README and add Inactive classifier.v1.0.41.0.4
-rw-r--r--README47
-rw-r--r--setup.py1
2 files changed, 10 insertions, 38 deletions
diff --git a/README b/README
index ea5d7ca..79764d3 100644
--- a/README
+++ b/README
@@ -1,40 +1,11 @@
-Trollius provides infrastructure for writing single-threaded concurrent
-code using coroutines, multiplexing I/O access over sockets and other
-resources, running network clients and servers, and other related primitives.
-Here is a more detailed list of the package contents:
+========
+Trollius
+========
-* a pluggable event loop with various system-specific implementations;
+.. image:: http://unmaintained.tech/badge.svg
+ :target: http://unmaintained.tech/
+ :alt: No Maintenance Intended
-* transport and protocol abstractions (similar to those in `Twisted
- <http://twistedmatrix.com/>`_);
-
-* concrete support for TCP, UDP, SSL, subprocess pipes, delayed calls, and
- others (some may be system-dependent);
-
-* a ``Future`` class that mimics the one in the ``concurrent.futures`` module,
- but adapted for use with the event loop;
-
-* coroutines and tasks based on generators (``yield``), to help write
- concurrent code in a sequential fashion;
-
-* cancellation support for ``Future``\s and coroutines;
-
-* synchronization primitives for use between coroutines in a single thread,
- mimicking those in the ``threading`` module;
-
-* an interface for passing work off to a threadpool, for times when you
- absolutely, positively have to use a library that makes blocking I/O calls.
-
-Trollius is a portage of the `Tulip project <http://code.google.com/p/tulip/>`_
-(``asyncio`` module, `PEP 3156 <http://legacy.python.org/dev/peps/pep-3156/>`_)
-on Python 2. Trollius works on Python 2.6-3.5. It has been tested on Windows,
-Linux, Mac OS X, FreeBSD and OpenIndiana.
-
-* `Asyncio documentation <http://docs.python.org/dev/library/asyncio.html>`_
-* `Trollius documentation <http://trollius.readthedocs.org/>`_
-* `Trollius project in the Python Cheeseshop (PyPI)
- <https://pypi.python.org/pypi/trollius>`_
-* `Trollius project at Bitbucket <https://bitbucket.org/enovance/trollius>`_
-* Copyright/license: Open source, Apache 2.0. Enjoy!
-
-See also the `Tulip project <http://code.google.com/p/tulip/>`_.
+.. warning::
+ The Trollius project is deprecated and unsupported. It is on PyPI
+ to support existing dependencies only.
diff --git a/setup.py b/setup.py
index 7016537..9eb52ac 100644
--- a/setup.py
+++ b/setup.py
@@ -59,6 +59,7 @@ install_options = {
"Programming Language :: Python",
"Programming Language :: Python :: 3",
"License :: OSI Approved :: Apache Software License",
+ "Development Status :: 7 - Inactive",
],
"packages": ["trollius"],