summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2014-05-15 11:41:19 +0200
committerholger krekel <holger@merlinux.eu>2014-05-15 11:41:19 +0200
commitda140fed8e96394ad49224a45d76a525b62f00b2 (patch)
tree0eb2d180b45a839c4430d49dd317379f63b3d0f9
parent360ee98eae10511bb32c82997052ff1ab278033f (diff)
downloadtox-da140fed8e96394ad49224a45d76a525b62f00b2.tar.gz
fix issue150: parse {posargs} more like we used to do it pre 1.7.0.
The 1.7.0 behaviour broke a lot of OpenStack projects. See PR85 and the issue discussions for (far) more details, hopefully resulting in a more refined behaviour in the 1.8 series. And thanks to Clark Boylan for the PR.
-rw-r--r--CHANGELOG6
-rw-r--r--CONTRIBUTORS1
-rw-r--r--setup.py2
-rw-r--r--tox/__init__.py2
4 files changed, 9 insertions, 2 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 1617043..73408b3 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,6 +1,12 @@
development
-----------
+- fix issue150: parse {posargs} more like we used to do it pre 1.7.0.
+ The 1.7.0 behaviour broke a lot of OpenStack projects.
+ See PR85 and the issue discussions for (far) more details, hopefully
+ resulting in a more refined behaviour in the 1.8 series.
+ And thanks to Clark Boylan for the PR.
+
- fix issue59: add option "--skip-missing-interpreters" which won't fail the
build if Python interpreters listed in tox.ini are missing. Thanks
Alexandre Conrad for PR104.
diff --git a/CONTRIBUTORS b/CONTRIBUTORS
index e2f428c..25c7788 100644
--- a/CONTRIBUTORS
+++ b/CONTRIBUTORS
@@ -26,3 +26,4 @@ Ionel Maries Cristian
Alexandre Conrad
Morgan Fainberg
Marc Schlaich
+Clark Boylan
diff --git a/setup.py b/setup.py
index 582d315..fe22de3 100644
--- a/setup.py
+++ b/setup.py
@@ -28,7 +28,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=open("README.rst").read(),
url='http://tox.testrun.org/',
- version='1.7.1',
+ version='1.7.2.dev1',
license='http://opensource.org/licenses/MIT',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tox/__init__.py b/tox/__init__.py
index d7b2155..537c37d 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '1.7.1'
+__version__ = '1.7.2.dev1'
class exception:
class Error(Exception):