summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2010-07-12 14:12:08 +0200
committerholger krekel <holger@merlinux.eu>2010-07-12 14:12:08 +0200
commitd0705b43f96bd6b5e8c84ac9e334fad73a444085 (patch)
treef5f87473d6ea3c6b7a2e6194f1b1101fdc296ae8
parent53a6a82ecfb131f8438f02fa9f91c72454b86a7a (diff)
downloadtox-d0705b43f96bd6b5e8c84ac9e334fad73a444085.tar.gz
bumping to next development version
-rw-r--r--CHANGELOG.txt6
-rw-r--r--setup.py28
-rw-r--r--tox/__init__.py2
3 files changed, 33 insertions, 3 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index 65b3932..59a39ee 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,5 +1,9 @@
+0.6
+-----------------
+
+- fix long description, thanks Michael Foord
-tox 0.5
+0.5
-----------------
- initial release
diff --git a/setup.py b/setup.py
index 766fe68..499cf5c 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,31 @@
import sys
from setuptools import setup
+long_description="""
+What is Tox?
+==========================
+
+Tox as is a generic virtualenv management and test command line tool you can
+use for:
+
+* checking your package installs correctly with different
+ Python versions and interpreters
+
+* running your tests in each of the
+ environments, configuring your test tool of choice
+
+* acting as a frontend to Continous Integration
+ servers, greatly reducing boilerplate and merging
+ CI and shell-based testing.
+
+For more information, docs and many examples please checkout the `home page`_:
+
+http://codespeak.net/tox
+
+.. _`home page`: http://codespeak.net/tox
+"""
+
+
def main():
install_requires=['virtualenv3==1.3.4.1']
if sys.version_info[0] < 3:
@@ -8,8 +33,9 @@ def main():
setup(
name='tox',
description='virtualenv-based automation of test activities',
+ long_description=long_description,
url='http://codespeak.net/tox',
- version='0.5',
+ version='0.6a1',
license='GPLv2 or later',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tox/__init__.py b/tox/__init__.py
index 6ed8f1f..8e37c91 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = "0.5"
+__version__ = "0.6a1"
import apipkg