summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorholger krekel <holger@merlinux.eu>2013-02-19 15:51:20 +0100
committerholger krekel <holger@merlinux.eu>2013-02-19 15:51:20 +0100
commit242a68e72200c53e727b4a23b0ec6a5e6161dfa9 (patch)
treec0f0ecd325d3beffa9ff5eca5c274d3a3c9a7532
parenta2d1ded419c267a890bfa717a6b434d7a2ec4f0a (diff)
downloadtox-242a68e72200c53e727b4a23b0ec6a5e6161dfa9.tar.gz
1.4.3
-rwxr-xr-xCHANGELOG2
-rw-r--r--doc/announce/release-1.4.3.txt94
-rw-r--r--setup.py2
-rw-r--r--tox/__init__.py2
4 files changed, 97 insertions, 3 deletions
diff --git a/CHANGELOG b/CHANGELOG
index 561d52f..256a5bc 100755
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,4 +1,4 @@
-1.4.3.dev
+1.4.3
-----------------
- introduce -l|--listenv option to list configured environments
diff --git a/doc/announce/release-1.4.3.txt b/doc/announce/release-1.4.3.txt
new file mode 100644
index 0000000..b57a0e4
--- /dev/null
+++ b/doc/announce/release-1.4.3.txt
@@ -0,0 +1,94 @@
+tox 1.4.3: the Python virtualenv-based testing automatizer
+=============================================================================
+
+tox 1.4.3 fixes some bugs and introduces a new script and two new options:
+
+- "tox-quickstart" - run this script, answer a few questions, and
+ get a tox.ini created for you (thanks Marc Abramowitz)
+
+- "tox -l" lists configured environment names (thanks Lukasz Balcerzak)
+
+- (experimental) "--installpkg=localpath" option which will skip the
+ sdist-creation of a package and instead install the given localpath package.
+
+Note that the sister project "detox" should continue to work - it's a
+separately released project which drives tox test runs on multiple CPUs
+in parallel.
+
+More documentation:
+
+ http://tox.testrun.org/
+
+Installation:
+
+ pip install -U tox
+
+code hosting and issue tracking on bitbucket:
+
+ https://bitbucket.org/hpk42/tox
+
+
+What is tox?
+----------------
+
+tox standardizes and automates tedious test activities driven from a
+simple ``tox.ini`` file, including:
+
+* creation and management of different virtualenv environments
+ with different Python interpreters
+* packaging and installing your package into each of them
+* running your test tool of choice, be it nose, py.test or unittest2 or other tools such as "sphinx" doc checks
+* testing dev packages against each other without needing to upload to PyPI
+
+best,
+Holger Krekel
+
+
+CHANGELOG
+================
+
+1.4.3 (compared to 1.4.2)
+--------------------------------
+
+- introduce -l|--listenv option to list configured environments
+ (thanks Lukasz Balcerzak)
+
+- fix downloadcache determination to work according to docs: Only
+ make pip use a download cache if PIP_DOWNLOAD_CACHE or a
+ downloadcache=PATH testenv setting is present. (The ENV setting
+ takes precedence)
+
+- fix issue84 - pypy on windows creates a bin not a scripts venv directory
+ (thanks Lukasz Balcerzak)
+
+- experimentally introduce --installpkg=PATH option to install a package rather than
+ create/install an sdist package. This will still require and use
+ tox.ini and tests from the current working dir (and not from the remote
+ package).
+
+- substitute {envsitepackagesdir} with the package installation directory (closes #72)
+ (thanks g2p)
+
+- issue #70 remove PYTHONDONTWRITEBYTECODE workaround now that
+ virtualenv behaves properly (thanks g2p)
+
+- merged tox-quickstart command, contributed by Marc Abramowitz, which
+ generates a default tox.ini after asking a few questions
+
+- fix #48 - win32 detection of pypy and other interpreters that are on PATH
+ (thanks Gustavo Picon)
+
+- fix grouping of index servers, it is now done by name instead of
+ indexserver url, allowing to use it to separate dependencies
+ into groups even if using the same default indexserver.
+
+- look for "tox.ini" files in parent dirs of current dir (closes #34)
+
+- the "py" environment now by default uses the current interpreter
+ (sys.executable) make tox' own setup.py test execute tests with it
+ (closes #46)
+
+- change tests to not rely on os.path.expanduser (closes #60),
+ also make mock session return args[1:] for more precise checking (closes #61)
+ thanks to Barry Warszaw for both.
+
diff --git a/setup.py b/setup.py
index d682c17..15fafea 100644
--- a/setup.py
+++ b/setup.py
@@ -49,7 +49,7 @@ def main():
description='virtualenv-based automation of test activities',
long_description=long_description,
url='http://tox.testrun.org/',
- version='1.4.3.dev7',
+ version='1.4.3',
license='GPLv2 or later',
platforms=['unix', 'linux', 'osx', 'cygwin', 'win32'],
author='holger krekel',
diff --git a/tox/__init__.py b/tox/__init__.py
index 657a40f..ea1ea01 100644
--- a/tox/__init__.py
+++ b/tox/__init__.py
@@ -1,5 +1,5 @@
#
-__version__ = '1.4.3.dev7'
+__version__ = '1.4.3'
class exception:
class Error(Exception):