summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernát Gábor <gaborjbernat@gmail.com>2023-04-05 09:20:49 -0700
committerGitHub <noreply@github.com>2023-04-05 09:20:49 -0700
commitf6e3dc97d0ecf1caa310b377ae948338c6fa67b8 (patch)
treec178410c25b5757efc41c9f411a33e1a31061be1
parent82584c900fddc5422b241e294e87cd72de5078c9 (diff)
downloadtox-git-f6e3dc97d0ecf1caa310b377ae948338c6fa67b8.tar.gz
Bump deps and tools (#2976)
-rw-r--r--.pre-commit-config.yaml8
-rw-r--r--pyproject.toml6
-rw-r--r--tox.ini20
3 files changed, 17 insertions, 17 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index d368db6a..745b1c40 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -29,7 +29,7 @@ repos:
hooks:
- id: isort
- repo: https://github.com/psf/black
- rev: 23.1.0
+ rev: 23.3.0
hooks:
- id: black
args: [--safe]
@@ -37,13 +37,13 @@ repos:
rev: 1.13.0
hooks:
- id: blacken-docs
- additional_dependencies: [black==23.1]
+ additional_dependencies: [black==23.3]
- repo: https://github.com/pre-commit/pygrep-hooks
rev: v1.10.0
hooks:
- id: rst-backticks
- repo: https://github.com/tox-dev/tox-ini-fmt
- rev: "0.6.1"
+ rev: "1.0.0"
hooks:
- id: tox-ini-fmt
args: ["-p", "fix"]
@@ -52,7 +52,7 @@ repos:
hooks:
- id: flake8
additional_dependencies:
- - flake8-bugbear==23.3.12
+ - flake8-bugbear==23.3.23
- flake8-comprehensions==3.11.1
- flake8-pytest-style==1.7.2
- flake8-spellcheck==0.28
diff --git a/pyproject.toml b/pyproject.toml
index ebb1ef78..0a084741 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -51,10 +51,10 @@ dependencies = [
"cachetools>=5.3",
"chardet>=5.1",
"colorama>=0.4.6",
- "filelock>=3.10",
+ "filelock>=3.10.7",
'importlib-metadata>=6.1; python_version < "3.8"',
"packaging>=23",
- "platformdirs>=3.1.1",
+ "platformdirs>=3.2",
"pluggy>=1",
"pyproject-api>=1.5.1",
'tomli>=2.0.1; python_version < "3.11"',
@@ -62,7 +62,7 @@ dependencies = [
"virtualenv>=20.21",
]
optional-dependencies.docs = [
- "furo>=2022.12.7",
+ "furo>=2023.3.27",
"sphinx>=6.1.3",
"sphinx-argparse-cli>=1.11",
"sphinx-autodoc-typehints!=1.23.4,>=1.22",
diff --git a/tox.ini b/tox.ini
index f86aedf6..61f87461 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,4 +1,5 @@
[tox]
+minversion = 3.22
envlist =
fix
py311
@@ -12,18 +13,19 @@ envlist =
pkg_meta
isolated_build = true
skip_missing_interpreters = true
-minversion = 3.22
[testenv]
description = run the tests with pytest under {envname}
+package = wheel
+wheel_build_env = .pkg
+extras =
+ testing
passenv =
PYTEST_*
SSL_CERT_FILE
setenv =
COVERAGE_FILE = {env:COVERAGE_FILE:{toxworkdir}{/}.coverage.{envname}}
COVERAGE_PROCESS_START = {toxinidir}{/}pyproject.toml
-extras =
- testing
commands =
pytest {posargs: \
--junitxml {toxworkdir}{/}junit.{envname}.xml --cov {envsitepackagesdir}{/}tox --cov {toxinidir}{/}tests \
@@ -33,17 +35,15 @@ commands =
-n={env:PYTEST_XDIST_AUTO_NUM_WORKERS:auto} \
tests --durations 5 --run-integration}
diff-cover --compare-branch {env:DIFF_AGAINST:origin/main} {toxworkdir}{/}coverage.{envname}.xml
-package = wheel
-wheel_build_env = .pkg
[testenv:fix]
description = format the code base to adhere to our styles, and complain about what we cannot do automatically
+skip_install = true
+deps =
+ pre-commit>=3.2.1
passenv =
{[testenv]passenv}
PROGRAMDATA
-skip_install = true
-deps =
- pre-commit>=3.2
commands =
pre-commit run --all-files --show-diff-on-failure {posargs}
python -c 'print(r"hint: run {envbindir}{/}pre-commit install to add checks as pre-commit hook")'
@@ -52,8 +52,8 @@ commands =
description = run type check on code base
deps =
mypy==1.1.1
- types-cachetools>=5.3.0.4
- types-chardet>=5.0.4.2
+ types-cachetools>=5.3.0.5
+ types-chardet>=5.0.4.3
commands =
mypy src/tox
mypy tests