summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernát Gábor <gaborjbernat@gmail.com>2023-02-05 13:50:31 -0800
committerGitHub <noreply@github.com>2023-02-05 13:50:31 -0800
commit80db13b780212af769e362dd4ad844bdfdc0b67a (patch)
tree0a06f7e63ccb08b6bada4b4d17fd4c7e62461a4e
parentb7fec1e236eeddefec9023f5d6ced94c5c2871cf (diff)
downloadtox-git-80db13b780212af769e362dd4ad844bdfdc0b67a.tar.gz
Bump deps and tools (#2913)
-rw-r--r--.pre-commit-config.yaml10
-rw-r--r--pyproject.toml87
-rw-r--r--src/tox/config/cli/ini.py1
-rw-r--r--src/tox/config/cli/parser.py8
-rw-r--r--src/tox/session/state.py1
-rw-r--r--tests/config/test_sets.py1
-rw-r--r--tests/tox_env/python/virtual_env/package/test_package_pyproject.py1
-rw-r--r--tox.ini4
8 files changed, 60 insertions, 53 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index eeeff763..13fd1c6e 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -29,7 +29,7 @@ repos:
hooks:
- id: isort
- repo: https://github.com/psf/black
- rev: 22.12.0
+ rev: 23.1.0
hooks:
- id: black
args: [--safe]
@@ -37,7 +37,7 @@ repos:
rev: 1.13.0
hooks:
- id: blacken-docs
- additional_dependencies: [black==22.12]
+ additional_dependencies: [black==23.1]
- repo: https://github.com/pre-commit/pygrep-hooks
rev: v1.10.0
hooks:
@@ -52,16 +52,16 @@ repos:
hooks:
- id: flake8
additional_dependencies:
- - flake8-bugbear==22.12.6
+ - flake8-bugbear==23.1.20
- flake8-comprehensions==3.10.1
- flake8-pytest-style==1.6
- flake8-spellcheck==0.28
- - flake8-unused-arguments==0.0.12
+ - flake8-unused-arguments==0.0.13
- flake8-noqa==1.3
- pep8-naming==0.13.3
- flake8-pyproject==1.2.2
- repo: https://github.com/pre-commit/mirrors-prettier
- rev: "v3.0.0-alpha.4"
+ rev: "v2.7.1"
hooks:
- id: prettier
additional_dependencies:
diff --git a/pyproject.toml b/pyproject.toml
index 0117ffbc..01d209dd 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,90 +1,101 @@
[build-system]
build-backend = "hatchling.build"
-requires = ["hatchling>=1.12.2", "hatch-vcs>=0.3"]
+requires = [
+ "hatch-vcs>=0.3",
+ "hatchling>=1.12.2",
+]
[project]
name = "tox"
description = "tox is a generic virtualenv management and test command line tool"
-readme.file = "README.md"
readme.content-type = "text/markdown"
-keywords = ["virtual", "environments", "isolated", "testing"]
+readme.file = "README.md"
+keywords = [
+ "environments",
+ "isolated",
+ "testing",
+ "virtual",
+]
license = "MIT"
-urls.Homepage = "http://tox.readthedocs.org"
-urls.Documentation = "https://tox.wiki"
-urls.Source = "https://github.com/tox-dev/tox"
-urls.Tracker = "https://github.com/tox-dev/tox/issues"
-urls."Release Notes" = "https://tox.wiki/en/latest/changelog.html"
-authors = [{ name = "Bernát Gábor", email = "gaborjbernat@gmail.com" }]
maintainers = [
{ name = "Anthony Sottile", email = "asottile@umich.edu" },
{ name = "Bernát Gábor", email = "gaborjbernat@gmail.com" },
{ name = "Jürgen Gmach", email = "juergen.gmach@googlemail.com" },
{ name = "Oliver Bestwalter", email = "oliver@bestwalter.de" },
]
+authors = [{ name = "Bernát Gábor", email = "gaborjbernat@gmail.com" }]
requires-python = ">=3.7"
+classifiers = [
+ "Development Status :: 5 - Production/Stable",
+ "Framework :: tox",
+ "Intended Audience :: Developers",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: MacOS :: MacOS X",
+ "Operating System :: Microsoft :: Windows",
+ "Operating System :: POSIX",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3 :: Only",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
+ "Topic :: Software Development :: Libraries",
+ "Topic :: Software Development :: Testing",
+ "Topic :: Utilities",
+]
+dynamic = [
+ "version",
+]
dependencies = [
- "cachetools>=5.2.1",
+ "cachetools>=5.3",
"chardet>=5.1",
"colorama>=0.4.6",
+ "filelock>=3.9",
+ 'importlib-metadata>=6; python_version < "3.8"',
"packaging>=23",
"platformdirs>=2.6.2",
"pluggy>=1",
"pyproject-api>=1.5",
'tomli>=2.0.1; python_version < "3.11"',
- "virtualenv>=20.17.1",
- "filelock>=3.9",
- 'importlib-metadata>=6; python_version < "3.8"',
'typing-extensions>=4.4; python_version < "3.8"',
+ "virtualenv>=20.17.1",
]
optional-dependencies.docs = [
"furo>=2022.12.7",
"sphinx>=6.1.3",
"sphinx-argparse-cli>=1.11",
- "sphinx-autodoc-typehints>=1.20.1",
+ "sphinx-autodoc-typehints!=1.23.4,>=1.22",
"sphinx-copybutton>=0.5.1",
"sphinx-inline-tabs>=2022.1.2b11",
"sphinxcontrib-towncrier>=0.2.1a0",
"towncrier>=22.12",
]
optional-dependencies.testing = [
- "build[virtualenv]>=0.9",
+ "build[virtualenv]>=0.10",
"covdefaults>=2.2.2",
"devpi-process>=0.3",
- "diff-cover>=7.3",
+ "diff-cover>=7.4",
"distlib>=0.3.6",
"flaky>=3.7",
"hatch-vcs>=0.3",
"hatchling>=1.12.2",
"psutil>=5.9.4",
- "pytest>=7.2",
+ "pytest>=7.2.1",
"pytest-cov>=4",
"pytest-mock>=3.10",
"pytest-xdist>=3.1",
"re-assert>=1.1",
+ 'time-machine>=2.8.2; implementation_name != "pypy"',
"wheel>=0.38.4",
- "time-machine>=2.8.2; implementation_name != \"pypy\"",
]
+urls.Documentation = "https://tox.wiki"
+urls.Homepage = "http://tox.readthedocs.org"
+urls."Release Notes" = "https://tox.wiki/en/latest/changelog.html"
+urls.Source = "https://github.com/tox-dev/tox"
+urls.Tracker = "https://github.com/tox-dev/tox/issues"
scripts.tox = "tox.run:run"
-dynamic = ["version"]
-classifiers = [
- "Development Status :: 5 - Production/Stable",
- "Framework :: tox",
- "Intended Audience :: Developers",
- "License :: OSI Approved :: MIT License",
- "Operating System :: MacOS :: MacOS X",
- "Operating System :: Microsoft :: Windows",
- "Operating System :: POSIX",
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3 :: Only",
- "Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: 3.8",
- "Programming Language :: Python :: 3.9",
- "Programming Language :: Python :: 3.10",
- "Programming Language :: Python :: 3.11",
- "Topic :: Software Development :: Libraries",
- "Topic :: Software Development :: Testing",
- "Topic :: Utilities",
-]
+
[tool.hatch]
build.dev-mode-dirs = ["src"]
diff --git a/src/tox/config/cli/ini.py b/src/tox/config/cli/ini.py
index c1823a1d..e4c71c90 100644
--- a/src/tox/config/cli/ini.py
+++ b/src/tox/config/cli/ini.py
@@ -33,7 +33,6 @@ class IniConfig:
if self.has_config_file:
self.config_file = self.config_file.absolute()
try:
-
parser = ConfigParser(interpolation=None)
with self.config_file.open() as file_handler:
parser.read_file(file_handler)
diff --git a/src/tox/config/cli/parser.py b/src/tox/config/cli/parser.py
index b7daeb15..aeee7f1f 100644
--- a/src/tox/config/cli/parser.py
+++ b/src/tox/config/cli/parser.py
@@ -178,13 +178,13 @@ class ToxParser(ArgumentParserWithEnvAndConfig):
self.handlers[cmd] = content
for alias in aliases:
self.handlers[alias] = content
- for (args, of_type, kwargs) in self._arguments:
+ for args, of_type, kwargs in self._arguments:
sub_parser.add_argument(*args, of_type=of_type, **kwargs)
- for (args, kwargs, excl) in self._groups:
+ for args, kwargs, excl in self._groups:
group = sub_parser.add_argument_group(*args, **kwargs)
- for (e_kwargs, arguments) in excl:
+ for e_kwargs, arguments in excl:
excl_group = group.add_mutually_exclusive_group(**e_kwargs)
- for (a_args, _, a_kwargs) in arguments:
+ for a_args, _, a_kwargs in arguments:
excl_group.add_argument(*a_args, **a_kwargs)
return sub_parser
diff --git a/src/tox/session/state.py b/src/tox/session/state.py
index 5bc7f2a7..df8c0473 100644
--- a/src/tox/session/state.py
+++ b/src/tox/session/state.py
@@ -9,7 +9,6 @@ from tox.plugin import impl
from .env_select import EnvSelector
if TYPE_CHECKING:
-
from tox.config.cli.parse import Options
from tox.config.cli.parser import ToxParser
diff --git a/tests/config/test_sets.py b/tests/config/test_sets.py
index f739b074..dc4debfd 100644
--- a/tests/config/test_sets.py
+++ b/tests/config/test_sets.py
@@ -142,7 +142,6 @@ def test_config_dynamic_not_equal(conf_builder: ConfBuilder) -> None:
def test_define_custom_set(tox_project: ToxProjectCreator) -> None:
class MagicConfigSet(ConfigSet):
-
SECTION = Section(None, "magic")
def register_config(self) -> None:
diff --git a/tests/tox_env/python/virtual_env/package/test_package_pyproject.py b/tests/tox_env/python/virtual_env/package/test_package_pyproject.py
index 0d6160a5..754be030 100644
--- a/tests/tox_env/python/virtual_env/package/test_package_pyproject.py
+++ b/tests/tox_env/python/virtual_env/package/test_package_pyproject.py
@@ -198,7 +198,6 @@ def test_pyproject_deps_static_with_dynamic(
dynamic: str,
deps: list[str],
) -> None:
-
monkeypatch.setenv("METADATA_EXTRA", metadata)
toml = f"{(demo_pkg_inline / 'pyproject.toml').read_text()}[project]\ndynamic={dynamic}"
ini = "[testenv]\nextras=alpha\n[testenv:.pkg]\npass_env=METADATA_EXTRA"
diff --git a/tox.ini b/tox.ini
index 2f803f23..e8812c65 100644
--- a/tox.ini
+++ b/tox.ini
@@ -52,7 +52,7 @@ commands =
description = run type check on code base
deps =
mypy==0.991
- types-cachetools>=5.2.1
+ types-cachetools>=5.3
types-chardet>=5.0.4.1
commands =
mypy src/tox
@@ -70,7 +70,7 @@ commands =
description = check that the long description is valid
skip_install = true
deps =
- build[virtualenv]>=0.9
+ build[virtualenv]>=0.10
check-wheel-contents>=0.4
twine>=4.0.2
commands =