summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernát Gábor <gaborjbernat@gmail.com>2022-12-13 08:17:12 -0800
committerGitHub <noreply@github.com>2022-12-13 08:17:12 -0800
commit4eaad6de5bb81e34c1688a40f8b6aa0ba6be0c3a (patch)
tree66b363ea5569925f622df995ca777ab673aacf50
parentf4c0c19dd5da28b589509c108637ba6f5b344e45 (diff)
parentebe1f3949e11279c065ebbcec0e916c04c83c10d (diff)
downloadtox-git-4eaad6de5bb81e34c1688a40f8b6aa0ba6be0c3a.tar.gz
Merge pull request #2703 from gaborbernat/release-4.0.9
-rw-r--r--docs/changelog.rst11
-rw-r--r--docs/changelog/2687.feature.rst2
-rw-r--r--docs/changelog/2700.feature.rst2
-rw-r--r--tests/session/cmd/test_show_config.py4
4 files changed, 13 insertions, 6 deletions
diff --git a/docs/changelog.rst b/docs/changelog.rst
index d440ee8e..cb5b7dbf 100644
--- a/docs/changelog.rst
+++ b/docs/changelog.rst
@@ -4,6 +4,17 @@ Release History
.. towncrier release notes start
+v4.0.9 (2022-12-13)
+-------------------
+
+Features - 4.0.9
+~~~~~~~~~~~~~~~~
+- Add :meth:`tox_on_install <tox.plugin.spec.tox_on_install>` and
+ :meth:`tox_env_teardown <tox.plugin.spec.tox_env_teardown>` plugin hooks - by :user:`gaborbernat`. (:issue:`2687`)
+- Add ``PKG_CONFIG_PATH`` to the default pass through environment list for python tox environments -
+ by :user:`gaborbernat`. (:issue:`2700`)
+
+
v4.0.8 (2022-12-11)
-------------------
diff --git a/docs/changelog/2687.feature.rst b/docs/changelog/2687.feature.rst
deleted file mode 100644
index fbf2165d..00000000
--- a/docs/changelog/2687.feature.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Add :meth:`tox_on_install <tox.plugin.spec.tox_on_install>` and
-:meth:`tox_env_teardown <tox.plugin.spec.tox_env_teardown>` plugin hooks - by :user:`gaborbernat`.
diff --git a/docs/changelog/2700.feature.rst b/docs/changelog/2700.feature.rst
deleted file mode 100644
index 671b489e..00000000
--- a/docs/changelog/2700.feature.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Add ``PKG_CONFIG_PATH`` to the default pass through environment list for python tox environments -
-by :user:`gaborbernat`.
diff --git a/tests/session/cmd/test_show_config.py b/tests/session/cmd/test_show_config.py
index e392adef..95b422ac 100644
--- a/tests/session/cmd/test_show_config.py
+++ b/tests/session/cmd/test_show_config.py
@@ -101,12 +101,12 @@ def test_pass_env_config_default(tox_project: ToxProjectCreator, stdout_is_atty:
(["COMSPEC"] if is_win else [])
+ ["CURL_CA_BUNDLE", "LANG", "LANGUAGE", "LD_LIBRARY_PATH"]
+ (["MSYSTEM", "NUMBER_OF_PROCESSORS", "PATHEXT"] if is_win else [])
- + ["PIP_*"]
+ + ["PIP_*", "PKG_CONFIG_PATH"]
+ (["PROCESSOR_ARCHITECTURE"] if is_win else [])
+ (["PROGRAMDATA"] if is_win else [])
+ (["PROGRAMFILES"] if is_win else [])
+ (["PROGRAMFILES(x86)"] if is_win else [])
- + ["PKG_CONFIG_PATH", "REQUESTS_CA_BUNDLE", "SSL_CERT_FILE"]
+ + ["REQUESTS_CA_BUNDLE", "SSL_CERT_FILE"]
+ (["SYSTEMDRIVE", "SYSTEMROOT", "TEMP"] if is_win else [])
+ (["TERM"] if stdout_is_atty else [])
+ (["TMP", "USERPROFILE"] if is_win else ["TMPDIR"])