summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernát Gábor <gaborjbernat@gmail.com>2023-04-19 11:07:36 -0700
committerGitHub <noreply@github.com>2023-04-19 11:07:36 -0700
commit3af29f0aaa3322bc13fc067ab534f6eb0ae6ed7a (patch)
tree1aa5f6a73c89fea94cafd4b09dc227c1384b1d90
parent0d85bdb9122a525cf879437c3287fb552efeb2a7 (diff)
downloadtox-git-3af29f0aaa3322bc13fc067ab534f6eb0ae6ed7a.tar.gz
Bump deps and tools (#2987)
-rw-r--r--.pre-commit-config.yaml2
-rw-r--r--pyproject.toml10
-rw-r--r--tox.ini2
3 files changed, 7 insertions, 7 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
index 29b28291..43128a4a 100644
--- a/.pre-commit-config.yaml
+++ b/.pre-commit-config.yaml
@@ -53,7 +53,7 @@ repos:
- id: flake8
additional_dependencies:
- flake8-bugbear==23.3.23
- - flake8-comprehensions==3.11.1
+ - flake8-comprehensions==3.12
- flake8-pytest-style==1.7.2
- flake8-spellcheck==0.28
- flake8-unused-arguments==0.0.13
diff --git a/pyproject.toml b/pyproject.toml
index 19ee5ec5..87c2ce55 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -52,8 +52,8 @@ dependencies = [
"chardet>=5.1",
"colorama>=0.4.6",
"filelock>=3.11",
- 'importlib-metadata>=6.2; python_version < "3.8"',
- "packaging>=23",
+ 'importlib-metadata>=6.4.1; python_version < "3.8"',
+ "packaging>=23.1",
"platformdirs>=3.2",
"pluggy>=1",
"pyproject-api>=1.5.1",
@@ -65,8 +65,8 @@ optional-dependencies.docs = [
"furo>=2023.3.27",
"sphinx>=6.1.3",
"sphinx-argparse-cli>=1.11",
- "sphinx-autodoc-typehints!=1.23.4,>=1.22",
- "sphinx-copybutton>=0.5.1",
+ "sphinx-autodoc-typehints!=1.23.4,>=1.23",
+ "sphinx-copybutton>=0.5.2",
"sphinx-inline-tabs>=2022.1.2b11",
"sphinxcontrib-towncrier>=0.2.1a0",
"towncrier>=22.12",
@@ -81,7 +81,7 @@ optional-dependencies.testing = [
"hatch-vcs>=0.3",
"hatchling>=1.14",
"psutil>=5.9.4",
- "pytest>=7.2.2",
+ "pytest>=7.3.1",
"pytest-cov>=4",
"pytest-mock>=3.10",
"pytest-xdist>=3.2.1",
diff --git a/tox.ini b/tox.ini
index 89812ed8..f546a5da 100644
--- a/tox.ini
+++ b/tox.ini
@@ -83,7 +83,7 @@ description = do a release, required posarg of the version number
skip_install = true
deps =
gitpython>=3.1.31
- packaging>=23
+ packaging>=23.1
towncrier>=22.12
commands =
python {toxinidir}/tasks/release.py --version {posargs}