summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernát Gábor <gaborjbernat@gmail.com>2021-09-16 09:49:48 +0100
committerBernát Gábor <gaborjbernat@gmail.com>2021-09-16 09:49:48 +0100
commitaa758d507d001f2791bab7a33c925237ef9b9243 (patch)
tree5638dd3fac346a1d976eeac6739a632988e72c25
parent95ffbb3718ecd70456e37408b93ee22c0258dfb5 (diff)
downloadtox-git-4.0.0a9.tar.gz
release 4.0.0a94.0.0a9
-rw-r--r--docs/changelog.rst33
-rw-r--r--docs/changelog/1881.doc.rst3
-rw-r--r--docs/changelog/2182.bugfix.rst1
-rw-r--r--docs/changelog/2191.feature.rst2
-rw-r--r--docs/changelog/2195.feature.rst1
-rw-r--r--docs/changelog/2200.feature.rst5
-rw-r--r--docs/changelog/2201.feature.rst3
-rw-r--r--docs/changelog/2209.bugfix.rst2
-rw-r--r--docs/changelog/2211.bugfix.rst1
-rw-r--r--docs/changelog/2213.bugfix.rst1
-rw-r--r--docs/changelog/2215.feature.rst1
11 files changed, 33 insertions, 20 deletions
diff --git a/docs/changelog.rst b/docs/changelog.rst
index b31d0678..dc08311a 100644
--- a/docs/changelog.rst
+++ b/docs/changelog.rst
@@ -4,6 +4,39 @@ Release History
.. towncrier release notes start
+v4.0.0a9 (2021-09-16)
+---------------------
+
+Features - 4.0.0a9
+~~~~~~~~~~~~~~~~~~
+- Expose the parsed CLI arguments on the main configuration object for plugins and allow plugins to define their own
+ configuration section -- by :user:`gaborbernat`. (`#2191 <https://github.com/tox-dev/tox/issues/2191>`_)
+- Let tox run fail when all envs are skipped -- by :user:`jugmac00`. (`#2195 <https://github.com/tox-dev/tox/issues/2195>`_)
+- Expose the configuration loading mechanism to plugins to define and load their own sections. Add
+ :meth:`tox_add_env_config <tox.plugin.spec.tox_add_env_config>` plugin hook called after the configuration environment
+ is created for a tox environment and removed ``tox_configure``. Add the main configuration object as argument to
+ :meth:`tox_add_core_config <tox.plugin.spec.tox_add_core_config>`. Move the environment list method from the state to
+ the main configuration object to allow its use within plugins -- by :user:`gaborbernat`. (`#2200 <https://github.com/tox-dev/tox/issues/2200>`_)
+- Allow running code in plugins before and after commands via
+ :meth:`tox_before_run_commands <tox.plugin.spec.tox_before_run_commands>` and
+ :meth:`tox_after_run_commands <tox.plugin.spec.tox_after_run_commands>` plugin points -- by :user:`gaborbernat`. (`#2201 <https://github.com/tox-dev/tox/issues/2201>`_)
+- Allow plugins to update the :ref:`set_env` and change the :ref:`pass_env` configurations -- by :user:`gaborbernat`. (`#2215 <https://github.com/tox-dev/tox/issues/2215>`_)
+
+Bugfixes - 4.0.0a9
+~~~~~~~~~~~~~~~~~~
+- Fix env variable substitutions with defaults containing colon (e.g. URL) -- by :user:`comabrewer`. (`#2182 <https://github.com/tox-dev/tox/issues/2182>`_)
+- Do not allow constructing ``ConfigSet`` directly and implement ``__contains__`` for ``Loader`` -- by
+ :user:`gaborbernat`. (`#2209 <https://github.com/tox-dev/tox/issues/2209>`_)
+- Fix old-new value on recreate cache miss-match are swapped -- by :user:`gaborbernat`. (`#2211 <https://github.com/tox-dev/tox/issues/2211>`_)
+- Report fails when report does not support Unicode characters -- by :user:`gaborbernat`. (`#2213 <https://github.com/tox-dev/tox/issues/2213>`_)
+
+Improved Documentation - 4.0.0a9
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+- Adopt furo theme, update our state diagram and description in user docs (SVG + light/dark variant), split
+ the Python API into its own page from under the plugin page, and document plugin adoption under the ``tox-dev``
+ organization - by :user:`gaborbernat`. (`#1881 <https://github.com/tox-dev/tox/issues/1881>`_)
+
+
v4.0.0a8 (2021-08-21)
---------------------
diff --git a/docs/changelog/1881.doc.rst b/docs/changelog/1881.doc.rst
deleted file mode 100644
index d352d501..00000000
--- a/docs/changelog/1881.doc.rst
+++ /dev/null
@@ -1,3 +0,0 @@
-Adopt furo theme, update our state diagram and description in user docs (SVG + light/dark variant), split
-the Python API into its own page from under the plugin page, and document plugin adoption under the ``tox-dev``
-organization - by :user:`gaborbernat`.
diff --git a/docs/changelog/2182.bugfix.rst b/docs/changelog/2182.bugfix.rst
deleted file mode 100644
index a7857725..00000000
--- a/docs/changelog/2182.bugfix.rst
+++ /dev/null
@@ -1 +0,0 @@
-Fix env variable substitutions with defaults containing colon (e.g. URL) -- by :user:`comabrewer`.
diff --git a/docs/changelog/2191.feature.rst b/docs/changelog/2191.feature.rst
deleted file mode 100644
index 2d5a5a1a..00000000
--- a/docs/changelog/2191.feature.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Expose the parsed CLI arguments on the main configuration object for plugins and allow plugins to define their own
-configuration section -- by :user:`gaborbernat`.
diff --git a/docs/changelog/2195.feature.rst b/docs/changelog/2195.feature.rst
deleted file mode 100644
index ae4d3f4c..00000000
--- a/docs/changelog/2195.feature.rst
+++ /dev/null
@@ -1 +0,0 @@
-Let tox run fail when all envs are skipped -- by :user:`jugmac00`.
diff --git a/docs/changelog/2200.feature.rst b/docs/changelog/2200.feature.rst
deleted file mode 100644
index 6927f31c..00000000
--- a/docs/changelog/2200.feature.rst
+++ /dev/null
@@ -1,5 +0,0 @@
-Expose the configuration loading mechanism to plugins to define and load their own sections. Add
-:meth:`tox_add_env_config <tox.plugin.spec.tox_add_env_config>` plugin hook called after the configuration environment
-is created for a tox environment and removed ``tox_configure``. Add the main configuration object as argument to
-:meth:`tox_add_core_config <tox.plugin.spec.tox_add_core_config>`. Move the environment list method from the state to
-the main configuration object to allow its use within plugins -- by :user:`gaborbernat`.
diff --git a/docs/changelog/2201.feature.rst b/docs/changelog/2201.feature.rst
deleted file mode 100644
index 9bd4610b..00000000
--- a/docs/changelog/2201.feature.rst
+++ /dev/null
@@ -1,3 +0,0 @@
-Allow running code in plugins before and after commands via
-:meth:`tox_before_run_commands <tox.plugin.spec.tox_before_run_commands>` and
-:meth:`tox_after_run_commands <tox.plugin.spec.tox_after_run_commands>` plugin points -- by :user:`gaborbernat`.
diff --git a/docs/changelog/2209.bugfix.rst b/docs/changelog/2209.bugfix.rst
deleted file mode 100644
index ec4e97c8..00000000
--- a/docs/changelog/2209.bugfix.rst
+++ /dev/null
@@ -1,2 +0,0 @@
-Do not allow constructing ``ConfigSet`` directly and implement ``__contains__`` for ``Loader`` -- by
-:user:`gaborbernat`.
diff --git a/docs/changelog/2211.bugfix.rst b/docs/changelog/2211.bugfix.rst
deleted file mode 100644
index 7584fd21..00000000
--- a/docs/changelog/2211.bugfix.rst
+++ /dev/null
@@ -1 +0,0 @@
-Fix old-new value on recreate cache miss-match are swapped -- by :user:`gaborbernat`.
diff --git a/docs/changelog/2213.bugfix.rst b/docs/changelog/2213.bugfix.rst
deleted file mode 100644
index 746b2f2c..00000000
--- a/docs/changelog/2213.bugfix.rst
+++ /dev/null
@@ -1 +0,0 @@
-Report fails when report does not support Unicode characters -- by :user:`gaborbernat`.
diff --git a/docs/changelog/2215.feature.rst b/docs/changelog/2215.feature.rst
deleted file mode 100644
index 93d6e974..00000000
--- a/docs/changelog/2215.feature.rst
+++ /dev/null
@@ -1 +0,0 @@
-Allow plugins to update the :ref:`set_env` and change the :ref:`pass_env` configurations -- by :user:`gaborbernat`.