summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOliver Bestwalter <oliver.bestwalter@avira.com>2018-04-02 18:05:14 +0200
committerOliver Bestwalter <oliver.bestwalter@avira.com>2018-04-02 18:11:16 +0200
commit35f82474e5ed71d0c05b6609b27538a61cf1faaf (patch)
tree7e017a61d1bccd529ab23a9556737bb76fd4b898
parenta2eb406488dbba70ce0e9e5fdad127030a0e80b3 (diff)
downloadtox-git-3.0.0.tar.gz
add a separate build step to pra script3.0.0
-rwxr-xr-xtasks/pra.sh6
1 files changed, 6 insertions, 0 deletions
diff --git a/tasks/pra.sh b/tasks/pra.sh
index 18acec01..ea7ea115 100755
--- a/tasks/pra.sh
+++ b/tasks/pra.sh
@@ -7,6 +7,7 @@ set -e
if [ -z "$1" ]; then
echo "workflow: $0 <command> [arg]"
echo " prep <version>"
+ echo " build"
echo " upload <devpi username>"
echo " test (optional)"
echo " release"
@@ -28,6 +29,8 @@ dispatch () {
exit 1
fi
prep
+ elif [ "$1" == "build" ]; then
+ build
elif [ "$1" == "upload" ]; then
devpi_upload $2
elif [ "$1" == "test" ]; then
@@ -50,6 +53,9 @@ prep () {
_confirm "commit changelog and tag repo as ${VERSION}?"
git commit -m "release preparation for ${VERSION}" || true
git tag -s ${VERSION} -m "release tox ${VERSION}" || true
+}
+
+build () {
rm dist/tox* || true
python setup.py sdist bdist_wheel
pip install -U dist/tox-${VERSION}.tar.gz