summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Nemec <bnemec@redhat.com>2018-09-17 22:31:29 +0000
committerBen Nemec <bnemec@redhat.com>2018-09-18 00:37:30 +0000
commitbd7cc62a737362f721b11462c540fd1db07ac457 (patch)
tree4c1e2829d1e826a276b161647a91c18717745198
parentf5accf53a015d906074dc81b21581bd6f850904f (diff)
downloadtooz-bd7cc62a737362f721b11462c540fd1db07ac457.tar.gz
Migrate to stestr
Change-Id: Id717f076d13f10697a7528139950a0b70d95c1c3
-rw-r--r--.gitignore7
-rw-r--r--.stestr.conf2
-rw-r--r--.testr.conf9
-rw-r--r--setup.cfg2
-rwxr-xr-xtools/pretty_tox.sh4
5 files changed, 8 insertions, 16 deletions
diff --git a/.gitignore b/.gitignore
index f1e7fde..09b6edb 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,21 +2,20 @@
*.egg
*.egg-info
build
-/.*
!.coveragerc
!.gitignore
!.mailmap
-!.testr.conf
.*.sw?
cover/*
covhtml
dist
.tox
+.coverage
# Generated by pbr
AUTHORS
ChangeLog
-# Generated by testrepository
-.testrepository
+# Generated by stestr
+.stestr/
# Generated by etcd
etcd-v*
default.etcd
diff --git a/.stestr.conf b/.stestr.conf
new file mode 100644
index 0000000..369fb08
--- /dev/null
+++ b/.stestr.conf
@@ -0,0 +1,2 @@
+[DEFAULT]
+test_path=tooz
diff --git a/.testr.conf b/.testr.conf
deleted file mode 100644
index 142a752..0000000
--- a/.testr.conf
+++ /dev/null
@@ -1,9 +0,0 @@
-[DEFAULT]
-test_command=OS_STDOUT_CAPTURE=${OS_STDOUT_CAPTURE:-1} \
- OS_STDERR_CAPTURE=${OS_STDERR_CAPTURE:-1} \
- OS_TEST_TIMEOUT=${OS_TEST_TIMEOUT:-160} \
- OS_DEBUG=${OS_DEBUG:-TRACE} \
- OS_LOG_CAPTURE=${OS_LOG_CAPTURE:-1} \
- ${PYTHON:-python} -m subunit.run discover tooz $LISTOPT $IDOPTION
-test_id_option=--load-list $IDFILE
-test_list_option=--list
diff --git a/setup.cfg b/setup.cfg
index 820266e..08f1cd7 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -65,12 +65,12 @@ ipc =
test =
mock>=2.0 # BSD
python-subunit>=0.0.18 # Apache-2.0/BSD
- testrepository>=0.0.18 # Apache-2.0/BSD
testtools>=1.4.0 # MIT
coverage>=3.6 # Apache-2.0
fixtures>=3.0.0 # Apache-2.0/BSD
pifpaf>=0.10.0 # Apache-2.0
os-testr>=0.8.0 # Apache-2.0
+ stestr>=2.0.0
doc =
sphinx>=1.6.2 # BSD
openstackdocstheme>=1.11.0 # Apache-2.0
diff --git a/tools/pretty_tox.sh b/tools/pretty_tox.sh
index 799ac18..150d506 100755
--- a/tools/pretty_tox.sh
+++ b/tools/pretty_tox.sh
@@ -10,7 +10,7 @@ TESTRARGS=$1
#
# this work around exists until that is addressed
if [[ "$TESTARGS" =~ "until-failure" ]]; then
- python setup.py testr --slowest --testr-args="$TESTRARGS"
+ stestr run --slowest "$TESTRARGS"
else
- python setup.py testr --slowest --testr-args="--subunit $TESTRARGS" | subunit-trace -f
+ stestr run --slowest --subunit "$TESTRARGS" | subunit-trace -f
fi