summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Harlow <harlowja@yahoo-inc.com>2014-09-24 21:00:09 -0700
committerJulien Danjou <julien@danjou.info>2014-10-06 11:11:56 +0200
commit74237d1e21c81a582b23074f60980b406100a10d (patch)
tree4ebf73a3985795a4bea599211b0af439d0e3472b
parentd00413cdfa02749e8e5d7ee83ac957ecc74cb1be (diff)
downloadtooz-74237d1e21c81a582b23074f60980b406100a10d.tar.gz
Split up the requirements for py2.x and py3.x
Certain requirements are not needed in py3.x since they exist in the base python tree so it is good to split off the requirements files and add the backported requirements to the py2.x requirements and not the py3.x requirements. The main current difference is the concurrent.futures package which is built-in to python 3.x as part of the standard library. Change-Id: I7274cb597eb1e84d13d37f99508f1bdabe108d8c
-rw-r--r--requirements-py3.txt12
-rw-r--r--tox.ini8
2 files changed, 20 insertions, 0 deletions
diff --git a/requirements-py3.txt b/requirements-py3.txt
new file mode 100644
index 0000000..c184aeb
--- /dev/null
+++ b/requirements-py3.txt
@@ -0,0 +1,12 @@
+pbr>=0.6,!=0.7,<1.0
+Babel>=1.3
+stevedore>=0.14
+six>=1.7.0
+iso8601
+kazoo>=1.3.1
+pymemcache>=1.2
+zake>=0.1.6
+sysv_ipc>=0.6.8
+msgpack-python
+retrying!=1.3.0
+oslo.utils>=1.0.0
diff --git a/tox.ini b/tox.ini
index 0b3984b..6631f9f 100644
--- a/tox.ini
+++ b/tox.ini
@@ -23,6 +23,14 @@ commands = bash -x {toxinidir}/setup-test-env.sh python setup.py testr --slowest
bash -x {toxinidir}/setup-test-env.sh {toxinidir}/run-examples.sh
doc8 doc/source
+[testenv:py33]
+deps = -r{toxinidir}/requirements-py3.txt
+ -r{toxinidir}/test-requirements.txt
+
+[testenv:py34]
+deps = -r{toxinidir}/requirements-py3.txt
+ -r{toxinidir}/test-requirements.txt
+
[testenv:cover]
commands =
bash -x {toxinidir}/setup-test-env.sh python setup.py testr --slowest --coverage --testr-args="{posargs}"