summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Parise <jon@indelible.org>2012-08-02 11:36:25 -0700
committerJon Parise <jon@indelible.org>2012-08-02 11:36:25 -0700
commitaec2d58ca6575bf0b00668ca1ce451e9562c1a7b (patch)
treee616523b4ac5d85213c65dade5176cef0ef39213
parent69cf3caf565c586d534b5071e024648ca27ff1a4 (diff)
downloadtimes-aec2d58ca6575bf0b00668ca1ce451e9562c1a7b.tar.gz
Remove the version-specific python-dateutil logic.
python-dateutil 2.1 is compatible with both Python 2.x and 3.x (with help from the six package).
-rw-r--r--setup.py11
1 files changed, 1 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 7d1fa0c..5c0e52a 100644
--- a/setup.py
+++ b/setup.py
@@ -11,15 +11,6 @@ def get_version():
return VERSION
raise RuntimeError('No version info found.')
-
-def get_dependencies():
- deps = ['pytz']
- if sys.version_info[0] == 3: # Python >= 3
- deps.append('python-dateutil >= 2')
- else:
- deps.append('python-dateutil < 2')
- return deps
-
setup(
name='times',
version=get_version(),
@@ -35,7 +26,7 @@ setup(
include_package_data=True,
zip_safe=False,
platforms='any',
- install_requires=get_dependencies(),
+ install_requires=['pytz', 'python-dateutil'],
classifiers=[
# As from http://pypi.python.org/pypi?%3Aaction=list_classifiers
#'Development Status :: 1 - Planning',