summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Driessen <vincent@3rdcloud.com>2012-02-03 21:13:30 +0100
committerVincent Driessen <vincent@3rdcloud.com>2012-02-03 21:13:30 +0100
commita8373a2aa233a1efe5583406ef57e5d1748fa349 (patch)
tree23da97f0c42fea62aac9bb659ca14ddfc1cafee4
parent8c485c2c6d8ca251492e90ac8c7337deb70b21fd (diff)
downloadtimes-a8373a2aa233a1efe5583406ef57e5d1748fa349.tar.gz
No need to store the version in a separate file for such a small project.
-rw-r--r--setup.py9
-rw-r--r--times/__init__.py4
-rw-r--r--times/version.py1
3 files changed, 3 insertions, 11 deletions
diff --git a/setup.py b/setup.py
index 7ad8c84..171f2fb 100644
--- a/setup.py
+++ b/setup.py
@@ -1,13 +1,8 @@
-import os
from setuptools import setup
def get_version():
- basedir = os.path.dirname(__file__)
- with open(os.path.join(basedir, 'times/version.py')) as f:
- VERSION = None
- exec(f.read())
- return VERSION
- raise RuntimeError('No version info found.')
+ from times import __version__
+ return __version__
setup(
name='times',
diff --git a/times/__init__.py b/times/__init__.py
index 2bdfd87..1e26cda 100644
--- a/times/__init__.py
+++ b/times/__init__.py
@@ -2,10 +2,8 @@ import datetime
import calendar
import pytz
-from .version import VERSION
-
__author__ = 'Vincent Driessen <vincent@3rdcloud.com>'
-__version__ = VERSION
+__version__ = '0.2'
def to_universal(local_dt, timezone=None):
diff --git a/times/version.py b/times/version.py
deleted file mode 100644
index 68c0733..0000000
--- a/times/version.py
+++ /dev/null
@@ -1 +0,0 @@
-VERSION = '0.2'