summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHugo van Kemenade <hugovk@users.noreply.github.com>2021-06-11 11:09:27 +0300
committerHugo van Kemenade <hugovk@users.noreply.github.com>2022-02-07 14:15:41 +0200
commit439890c9e56a90e396564cf2e6cd578b9230e2bf (patch)
treea65bb13fb8f0e2d2f36aa074da93a29510478685
parent2442ca249c7675a990fd23f1497936f8c16eb90a (diff)
downloadtesttools-439890c9e56a90e396564cf2e6cd578b9230e2bf.tar.gz
Drop support for EOL Python 3.5
-rw-r--r--.github/workflows/test.yml2
-rw-r--r--NEWS3
-rw-r--r--README.rst2
-rw-r--r--doc/hacking.rst2
-rw-r--r--doc/overview.rst4
-rwxr-xr-xscripts/all-pythons2
-rw-r--r--setup.cfg1
-rwxr-xr-xsetup.py2
-rw-r--r--tox.ini2
9 files changed, 11 insertions, 9 deletions
diff --git a/.github/workflows/test.yml b/.github/workflows/test.yml
index 44c27b7..a52e0ad 100644
--- a/.github/workflows/test.yml
+++ b/.github/workflows/test.yml
@@ -8,7 +8,7 @@ jobs:
strategy:
fail-fast: false
matrix:
- python-version: [3.5, 3.6, 3.7, 3.8, 3.9, "3.10", pypy3]
+ python-version: [3.6, 3.7, 3.8, 3.9, "3.10", pypy3]
steps:
- uses: actions/checkout@v2
diff --git a/NEWS b/NEWS
index b9c7b1b..91068c2 100644
--- a/NEWS
+++ b/NEWS
@@ -12,6 +12,9 @@ Improvements
* Add support for Python 3.10.
(Jürgen Gmach)
+* Drop support for Python 3.5 (EOL).
+ (Hugo van Kemenade)
+
* Distutils integration is deprecated and will be removed in the next major
version.
diff --git a/README.rst b/README.rst
index df8302d..3a377fe 100644
--- a/README.rst
+++ b/README.rst
@@ -34,7 +34,7 @@ under the same license as Python, see LICENSE for details.
Supported platforms
-------------------
- * Python 3.5+ or PyPy3
+ * Python 3.6+ or PyPy3
If you would like to use testtools for earlier Pythons, consult the compatibility docs:
diff --git a/doc/hacking.rst b/doc/hacking.rst
index d0ded96..6cb6423 100644
--- a/doc/hacking.rst
+++ b/doc/hacking.rst
@@ -15,7 +15,7 @@ Coding style
In general, follow `PEP 8`_ except where consistency with the standard
library's unittest_ module would suggest otherwise.
-testtools supports Python 3.5 and later.
+testtools supports Python 3.6 and later.
Copyright assignment
--------------------
diff --git a/doc/overview.rst b/doc/overview.rst
index 4681933..e978420 100644
--- a/doc/overview.rst
+++ b/doc/overview.rst
@@ -84,7 +84,7 @@ Cross-Python compatibility
--------------------------
testtools gives you the very latest in unit testing technology in a way that
-will work with Python 3.5+ and PyPy3.
+will work with Python 3.6+ and PyPy3.
If you wish to use testtools with Python 2.4 or 2.5, then please use testtools
0.9.15.
@@ -94,4 +94,4 @@ If you wish to use testtools with Python 2.6 or 3.2, then please use testtools
If you wish to use testtools with Python 3.3 or 3.4, then please use testtools 2.3.0.
-If you wish to use testtools with Python 2.7, then please use testtools 2.4.0.
+If you wish to use testtools with Python 2.7 or 3.5, then please use testtools 2.4.0.
diff --git a/scripts/all-pythons b/scripts/all-pythons
index 0fbe010..28793ec 100755
--- a/scripts/all-pythons
+++ b/scripts/all-pythons
@@ -89,5 +89,5 @@ def now():
if __name__ == '__main__':
sys.path.append(ROOT)
result = TestProtocolClient(sys.stdout)
- for version in '3.5 3.6 3.7 3.8 3.9 3.10'.split():
+ for version in '3.6 3.7 3.8 3.9 3.10'.split():
run_for_python(version, result, sys.argv[1:])
diff --git a/setup.cfg b/setup.cfg
index c31f8f3..e9cbecd 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -12,7 +12,6 @@ classifier =
Operating System :: OS Independent
Programming Language :: Python
Programming Language :: Python :: 3
- Programming Language :: Python :: 3.5
Programming Language :: Python :: 3.6
Programming Language :: Python :: 3.7
Programming Language :: Python :: 3.8
diff --git a/setup.py b/setup.py
index 3aa9218..e76930c 100755
--- a/setup.py
+++ b/setup.py
@@ -11,7 +11,7 @@ except:
setuptools.setup(
- python_requires='>=3.5',
+ python_requires='>=3.6',
cmdclass=cmd_class,
setup_requires=['pbr'],
pbr=True)
diff --git a/tox.ini b/tox.ini
index 0416e06..82ce299 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py35,py36,py37,py38,py39,py310,pypy3
+envlist = py36,py37,py38,py39,py310,pypy3
minversion = 1.6
[testenv]