summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2022-11-19 14:43:26 +0000
committerJelmer Vernooij <jelmer@jelmer.uk>2022-11-19 14:43:26 +0000
commit347a27dd5a95a890ac1d615e46e94d9676dd2f48 (patch)
tree57447fc2c79d281e310ddecf67470046d23d4c28
parent58d5c3f9b91f572e1fa174f5472e3d0a92f948c3 (diff)
downloadtesttools-347a27dd5a95a890ac1d615e46e94d9676dd2f48.tar.gz
Add initial config for mypy.
-rw-r--r--pyproject.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..e6c1020
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,13 @@
+[tool.mypy]
+warn_redundant_casts = true
+warn_unused_configs = true
+check_untyped_defs = true
+
+[[tool.mypy.overrides]]
+module = [
+ "fixtures.*",
+ "testresources.*",
+ "testscenarios.*",
+ "pbr.*",
+]
+ignore_missing_imports = true