summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJelmer Vernooij <jelmer@jelmer.uk>2022-11-19 18:21:38 +0000
committerGitHub <noreply@github.com>2022-11-19 18:21:38 +0000
commit2fc09e4f64e51148d1245b287dec84717a0f353a (patch)
tree5d60158c01f2253ced9270ecbe22d7e1220e4e40
parentd602d9a2532fa952647f635a2e97fe3de3cec49b (diff)
parent142cb77e2b85bd606be16208ca55012b8eff136a (diff)
downloadtesttools-2fc09e4f64e51148d1245b287dec84717a0f353a.tar.gz
Merge pull request #337 from testing-cabal/mypy
Add initial config for mypy
-rw-r--r--pyproject.toml13
1 files changed, 13 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..e6c1020
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,13 @@
+[tool.mypy]
+warn_redundant_casts = true
+warn_unused_configs = true
+check_untyped_defs = true
+
+[[tool.mypy.overrides]]
+module = [
+ "fixtures.*",
+ "testresources.*",
+ "testscenarios.*",
+ "pbr.*",
+]
+ignore_missing_imports = true