summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2012-04-04 22:46:52 +1200
committerRobert Collins <robertc@robertcollins.net>2012-04-04 22:46:52 +1200
commit475857af19a8190c9c0c7f8241b9907b942e19fd (patch)
tree4378848ade511e4e8a1d44f76fba09c4a27a0e51
parent4f60358a8cd193d4c52ec04cd3dd299396434fdf (diff)
downloadtestscenarios-475857af19a8190c9c0c7f8241b9907b942e19fd.tar.gz
Release 0.3 (and fixup NEWS).
-rw-r--r--NEWS15
-rw-r--r--lib/testscenarios/__init__.py2
-rwxr-xr-xsetup.py2
3 files changed, 11 insertions, 8 deletions
diff --git a/NEWS b/NEWS
index b3ff2dc..0d1663a 100644
--- a/NEWS
+++ b/NEWS
@@ -6,15 +6,22 @@ testscenarios release notes
IN DEVELOPMENT
~~~~~~~~~~~~~~
-0.2
+0.3
~~~
-NEW FEATURES:
+CHANGES:
* New function ``per_module_scenarios`` for tests that should be applied across
multiple modules providing the same interface, some of which may not be
available at run time. (Martin Pool)
+* ``TestWithScenarios`` is now backed by a mixin - WithScenarios - which can be
+ mixed into different unittest implementations more cleanly (e.g. unittest2).
+ (James Polley, Robert Collins)
+
+0.2
+~~~
+
CHANGES:
* Adjust the cloned tests ``shortDescription`` if one is present. (Ben Finney)
@@ -22,10 +29,6 @@ CHANGES:
* Provide a load_tests implementation for easy use, and multiply_scenarios to
create the cross product of scenarios. (Martin Pool)
-* ``TestWithScenarios`` is now backed by a mixin - WithScenarios - which can be
- mixed into different unittest implementations more cleanly (e.g. unittest2).
- (James Polley, Robert Collins)
-
0.1
~~~
diff --git a/lib/testscenarios/__init__.py b/lib/testscenarios/__init__.py
index f8cb056..356dc41 100644
--- a/lib/testscenarios/__init__.py
+++ b/lib/testscenarios/__init__.py
@@ -38,7 +38,7 @@ methods for details.
# established at this point, and setup.py will use a version of next-$(revno).
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (0, 2, 0, 'final', 0)
+__version__ = (0, 3, 0, 'final', 0)
__all__ = [
'TestWithScenarios',
diff --git a/setup.py b/setup.py
index ace9f08..6116557 100755
--- a/setup.py
+++ b/setup.py
@@ -6,7 +6,7 @@ import os.path
description = file(os.path.join(os.path.dirname(__file__), 'README'), 'rb').read()
setup(name="testscenarios",
- version="0.2",
+ version="0.3",
description="Testscenarios, a pyunit extension for dependency injection",
long_description=description,
maintainer="Robert Collins",