summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml17
-rw-r--r--setup.cfg2
2 files changed, 17 insertions, 2 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..88b5ffd
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,17 @@
+sudo: false
+language: python
+python:
+ - "2.7"
+ - "3.4"
+ - "3.5"
+ - "3.6"
+ - pypy
+ - pypy3.5
+install:
+ - pip install -U pip
+ - pip install -U wheel setuptools
+ - pip install -r requirements.txt
+ - pip list
+ - python --version
+script:
+ - python setup.py test
diff --git a/setup.cfg b/setup.cfg
index 52a7a48..a455d0b 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -18,8 +18,6 @@ classifier =
[test]
test_module = testscenarios.tests
-buffer=1
-catch=1
[bdist_wheel]
universal = 1