summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2009-12-12 17:27:06 +1100
committerRobert Collins <robertc@robertcollins.net>2009-12-12 17:27:06 +1100
commit075c5cc3fbdf85a71a4c55d1bc92de941eb65626 (patch)
treeb0bae4de318efd66d4e06fec1f862308b6f5fb14
parent35afae1366c57db72189c8348afbb31f297521f6 (diff)
downloadtestresources-075c5cc3fbdf85a71a4c55d1bc92de941eb65626.tar.gz
Fix build errors with recent testtools.
-rw-r--r--NEWS27
-rw-r--r--lib/testresources/tests/test_optimising_test_suite.py2
-rwxr-xr-xsetup.py2
3 files changed, 23 insertions, 8 deletions
diff --git a/NEWS b/NEWS
index a5fb382..e47b9fa 100644
--- a/NEWS
+++ b/NEWS
@@ -2,19 +2,34 @@
testresources release notes
---------------------------
-
IN DEVELOPMENT
--------------
- CHANGES:
+CHANGES
+~~~~~~~
- IMPROVEMENTS:
+IMPROVEMENTS
+~~~~~~~~~~~~
- BUG FIXES:
+BUG FIXES
+~~~~~~~~~
- API CHANGES:
+API CHANGES
+~~~~~~~~~~~
- INTERNALS:
+INTERNALS
+~~~~~~~~~
+
+0.2.1
+------
+
+A small bugfix release for compatibility with newer testtools.
+
+INTERNALS
+~~~~~~~~~
+
+* One test case wasn't upcalling setUp properly, causing test failures with
+ more recent testtools that check for this mistake.
0.2
---
diff --git a/lib/testresources/tests/test_optimising_test_suite.py b/lib/testresources/tests/test_optimising_test_suite.py
index 0446d36..4176bf7 100644
--- a/lib/testresources/tests/test_optimising_test_suite.py
+++ b/lib/testresources/tests/test_optimising_test_suite.py
@@ -414,7 +414,7 @@ class TestCostGraph(testtools.TestCase):
class TestGraphStuff(testtools.TestCase):
def setUp(self):
-
+ testtools.TestCase.setUp(self)
class MockTest(unittest.TestCase):
def __repr__(self):
"""The representation is the tests name.
diff --git a/setup.py b/setup.py
index 04ddcd6..57fea17 100755
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
from distutils.core import setup
setup(name="testresources",
- version="0.2",
+ version="0.2.1",
description="Testresources, a pyunit extension for managing expensive "
"test resources",
maintainer="Test Resources developers",