summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2013-07-17 21:06:17 +1200
committerRobert Collins <robertc@robertcollins.net>2013-07-17 21:06:17 +1200
commite181eb9a5292eeb88cbe3cd7455c36f4d24bb77d (patch)
tree69d5b91ec3e5a23cd36fcf2530536ccd76c596a0
parente4e384e673b7088082e7d144df50ef934cf8c4e3 (diff)
downloadtestrepository-e181eb9a5292eeb88cbe3cd7455c36f4d24bb77d.tar.gz
0.0.170.0.17
++++++ * Restore the ability to import testrepository.repository.memory on Python 2.6. (Robert Collins)
-rw-r--r--NEWS9
-rw-r--r--testrepository/__init__.py2
-rw-r--r--testrepository/repository/memory.py4
3 files changed, 13 insertions, 2 deletions
diff --git a/NEWS b/NEWS
index 11b7a5c..6ef6509 100644
--- a/NEWS
+++ b/NEWS
@@ -5,6 +5,15 @@ testrepository release notes
NEXT (In development)
+++++++++++++++++++++
+0.0.17
+++++++
+
+CHANGES
+-------
+
+* Restore the ability to import testrepository.repository.memory on Python 2.6.
+ (Robert Collins)
+
0.0.16
++++++
diff --git a/testrepository/__init__.py b/testrepository/__init__.py
index c582aeb..58bae71 100644
--- a/testrepository/__init__.py
+++ b/testrepository/__init__.py
@@ -33,4 +33,4 @@ The tests package contains tests and test specific support code.
# established at this point, and setup.py will use a version of next-$(revno).
# If the releaselevel is 'final', then the tarball will be major.minor.micro.
# Otherwise it is major.minor.micro~$(revno).
-__version__ = (0, 0, 16, 'final', 0)
+__version__ = (0, 0, 17, 'final', 0)
diff --git a/testrepository/repository/memory.py b/testrepository/repository/memory.py
index 07eb667..594128a 100644
--- a/testrepository/repository/memory.py
+++ b/testrepository/repository/memory.py
@@ -14,7 +14,9 @@
"""In memory storage of test results."""
-from collections import OrderedDict
+from extras import try_import
+
+OrderedDict = try_import('collections.OrderedDict', dict)
from io import BytesIO
from operator import methodcaller