summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Collins <robertc@robertcollins.net>2015-07-12 20:45:22 +1200
committerRobert Collins <robertc@robertcollins.net>2015-07-12 20:45:22 +1200
commitb4f9df3b93239da17ffc6359b2085dfb85922a1c (patch)
tree25a871d3d19786d8743997566aa379f27c75e42d
parentea2d5cec81a8cd7632a1b3a3aa45c0461f58829c (diff)
downloadtestrepository-b4f9df3b93239da17ffc6359b2085dfb85922a1c.tar.gz
Setup travis.
-rw-r--r--.travis.yml26
1 files changed, 26 insertions, 0 deletions
diff --git a/.travis.yml b/.travis.yml
new file mode 100644
index 0000000..a4de1fc
--- /dev/null
+++ b/.travis.yml
@@ -0,0 +1,26 @@
+sudo: false
+language: python
+python:
+ - "2.6"
+ - "2.7"
+ - "3.2"
+ - "3.3"
+ - "3.4"
+ - pypy
+ - pypy3
+matrix:
+ include:
+# Travis nightly look to be 3.5.0a4, b3 is out and the syntax error we see
+# doesn't happen in trunk.
+ - python: "nightly"
+ env: SKIP_DOCS=1
+install:
+ - pip install -U pip
+ - pip install -U wheel setuptools
+ - pip install -U .[docs,test]
+ - pip list
+ - python --version
+script:
+ - make check
+ - if [ -z "$SKIP_DOCS" ]; then python setup.py build_sphinx; fi
+ - rst2html.py README.rst README.html